XUL custom treeview throws a permission denied error when selecting a row (non-chrome XUL)

RESOLVED DUPLICATE of bug 209701

Status

()

RESOLVED DUPLICATE of bug 209701
13 years ago
10 years ago

People

(Reporter: deck_hockey, Assigned: janv)

Tracking

({regression})

1.8 Branch
x86
Windows NT
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

1.12 KB, application/vnd.mozilla.xul+xml
Details
1.84 KB, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.8b2) Gecko/20050623 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.8b2) Gecko/20050623 Firefox/1.0+

See steps

Reproducible: Always

Steps to Reproduce:
1. Open the URL provided (a custom treeview example from XUL Planet)
2. Attempt to select a row
3. Notice that an exception is thrown:
Error: uncaught exception: Permission denied to create wrapper for object of
class UnnamedClass

The sample is not erring because of a TreeColumn being passed to the
"getCellText" method (instead of an ID-string), but due to some other factor.

Actual Results:  
Error: uncaught exception: Permission denied to create wrapper for object of
class UnnamedClass

Expected Results:  
The tree-view row should be selected, as in the default tree view control.

Comment 1

13 years ago
Created attachment 196209 [details]
example

Code from the web site

Comment 2

13 years ago
Created attachment 196210 [details]
example (correct)

first example had a syntax error.

I am getting the same effect in my own custom view backed trees, but only with
the  ff 1.5 beta 1
Attachment #196209 - Attachment is obsolete: true

Comment 3

13 years ago
So your problem is with non-chrome XUL trees, right?
Assignee: nobody → Jan.Varga
Status: UNCONFIRMED → NEW
Component: General → XP Toolkit/Widgets: Trees
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → xptoolkit.trees
Summary: XUL custom treeview throws an error when selecting a row → XUL custom treeview throws a permission denied error when selecting a row (non-chrome XUL)
Version: unspecified → 1.8 Branch

Comment 4

13 years ago
(In reply to comment #3)
> So your problem is with non-chrome XUL trees, right?

Yes it is, I haven't tried from chrome, but the UnnamedClass seems to only apply
to non-chrome xul.

Comment 5

13 years ago
Created attachment 197905 [details]
example with work-around

This attachemnt is slightly modified to provide a nsISupports interface which
then reports that it supports nsITreeView. Code shamelessly stolen from: 

http://www.xulplanet.com/tutorials/xulqa/q_treebview.html

Is this an intentional change, or a bug?
I believe this bug to cover the same issue as bug 209701.  Unlike this bug,
however, bug 209701 has at least an attempt at a patch.  I am therefore
resolving this bug as a duplicate of bug 209701.  Feel free to reopen if you
disagree.

*** This bug has been marked as a duplicate of 209701 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.trees → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.