Files downloaded using firefox do not have their original date preserved as they do with wget

VERIFIED DUPLICATE of bug 178506

Status

()

defect
VERIFIED DUPLICATE of bug 178506
14 years ago
2 years ago

People

(Reporter: A.Sloman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

The date shown for the summary-gc7.pdf file should be 14th April 2005
  19486 Apr 14 02:03 summary-gc7.pdf
When I download using firefox (or mozilla) the date shown is the date of
downloading. This loses very important information about files. People who
want to use the download date can easily use 'touch' (at least on unix and linux
systems). But at present I am forced to use wget instead of firefox when I want
date information preserved. This is often a nuisance as I have to select url in
firefox and paste it onto the command line to run wget. 

Reproducible: Always

Steps to Reproduce:
1. Download any file whose last-modfied date you know
2. Check the date shown on the download file

I don't use windows myself, but I think firefox has the same problem
on my wife's windows machine.
Actual Results:  
Wrong date shown
  19486 Jul 14 00:41 summary-gc7.pdf

Expected Results:  
 19486 Apr 14 02:03 summary-gc7.pdf

This fault has always existed as far as I know.
*** Bug 300704 has been marked as a duplicate of this bug. ***
*** This bug has been marked as a duplicate of 178506 ***

*** This bug has been marked as a duplicate of 178506 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Apologies for accidentally submitting twice. I was trying to 'vote for this bug'
and it would not allow me to check the bug, so I tried going back and then
forward. 300704 could be deleted completely.

I also apologise for not finding 178506 before posting. I tried checking for
duplicates, but searching for
  download date
somehow did not bring it up.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.