Closed Bug 300710 Opened 16 years ago Closed 8 years ago

[Mac] No context menus for bookmarks in toolbar folders

Categories

(Firefox :: Bookmarks & History, enhancement, P4)

All
macOS
enhancement

Tracking

()

VERIFIED FIXED
Firefox 28
Tracking Status
relnote-firefox --- -

People

(Reporter: jruderman, Assigned: masayuki)

References

Details

(Keywords: uiwanted, Whiteboard: [parity-Chrome])

Attachments

(2 files, 1 obsolete file)

Steps to reproduce:
1. Create a bookmark folder on the bookmarks toolbar and put an item in it.
2. Open the menu by clicking it.
3. Ctrl+click an item in the menu.

Result: the bookmark loads.

Expected: context menu for the bookmark with 'delete', etc. like on Windows.

This feature was removed in bug 260549 because it was buggy (not a good reason;
fix the bug), because it's not consistent with other Mac browsers (not a good
reason; nothing wrong with being better than other browsers), and/or because on
Mac it's weird on for different types of clicks on menu items to have different
actions (not a good reason; Firefox honors other modifiers in the same menu). 
Consistency with the platform is not a good enough reason to omit a feature this
useful.
It was removed because right click in mac menus fires the menu item command
(just like left click).
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WONTFIX
*** Bug 322868 has been marked as a duplicate of this bug. ***
Wont fix is not good enough.  I'm sorry, this needs to be reopened.
*** Bug 322868 has been marked as a duplicate of this bug. ***
*** Bug 340924 has been marked as a duplicate of this bug. ***
*** Bug 340155 has been marked as a duplicate of this bug. ***
*** Bug 303330 has been marked as a duplicate of this bug. ***
*** Bug 350339 has been marked as a duplicate of this bug. ***
If this bug is not fixed, the bookmark toolbar behaves inconsistent. One cannot have a context menu on top level entries but not on drop-down entries.

Please re-open this bug.
*** Bug 355325 has been marked as a duplicate of this bug. ***
I don't know how open Apple normally is to bug reports and feature requests from third parties, but with them only recently becoming more supportive of using multiple mouse buttons, maybe this is something at least worth reporting to Apple and seeing if they'd be interested in making the change?  Seems like Safari at least and potentially other Apple programs have just as much to gain from making this possible.
This is not a rant, but a statement: marking this as a WONFIX is about enough to finally, sadly, wean me away from using Firefox as my default browser. This is not an Apple problem, but a Firefox problem. I'm sure this is a major annoyance and usability problem for a good number of users. I would call this a "minor bug", not an "enhancement" -- submenus act differently than the root menu in the bookmark toolbar.  Fixing that would be fixing a bug in this program. 

WONTFIX is, IMHO, not a good option for this bug -- and it IS a bug, not a "feature". If someone would at the very least explain why this was marked as a WONTFIX, I, and I'm sure at least a few others,  would appreciate it.
Mike: I'm curious, what browser is it going to wean you away from Firefox *to*? What other Mac browsers allow context menus on bookmark toolbar folder menu items?
(In reply to comment #13)
Yes, I'm curious too, this has been annoying me ever since I switched to Mac and if I can find a browser that allows me to organise my bookmarks easily without opening another window I might just switch away from Firefox.
No good reason was given for wontfixing this bug (in comment 1), especially given comment 0, so I'm reopening it.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
If we're going to do this, it might need some widget hackery to make two popups be displayed at the same time. 

bug 339447 will probably change how popups work in the cocoa widget code, so it's probably a good idea to wait for that before (potentially) starting work on this. marking dependency.
Depends on: 339447
Another vote to have this fixed, please. Contextual menus work just fine elsewhere in Firefox:Mac, and it's a real pain to not be able to select an alternate action from the bookmarks toolbar.

Especially when it "does" work in the bookmarks sidebar, which shows that it is possible. Not everyone uses the sidebar, however, so this should work "across the board", so to speak.
I too cast my vote to have this bug addressed. As said above, contextual menus work great everywhere else in Firefox on my Mac, why not in the bookmarks toolbar?

This is my one and only complaint about Firefox for the Mac. I have converted to a Mac from many years using a PC and immediately noticed the bug.
I too would like this to be fixed. I am in a similar boat as Mr. Slay. I experienced the same frustration and even tried several alternative browsers. 

It is hard to 'sell' Firefox to people if bugs like this (reminiscent of problems with IE) exist. Keep the 'edge' and fix this bug please.
Duplicate of this bug: 374539
I'm not sure if this is the same bug or not, but I think that this bug causes loss of functionality with some extensions.

The one that I've run into most is, when using TMP's session manager on a mac, there is no way to delete an old session (because the only way to do it requires a control click).

Even aside from that specific, extensions are going to use right mouse on a menu item periodically, and it would be nice if that did what the author thought it would.

Given that bug 339447 seems to have been fixed, will this bug be fixed soon?

Thank you very much.  Be well.
Another vote for this to be fixed.
Flags: blocking-firefox3?
Not blocking, far too late for changes of this type.
Flags: blocking-firefox3? → blocking-firefox3-
OK, "far too late"? It's been three years! Can someone genuinely explain to me what is so complicated about this bug? Those who volunteer on the Mac side, I would think, are geeky enough to want to use their right mouse button, even on a Macintosh. Perhaps if someone can explain the issue, maybe I can help fix it? This is absurd... I realize we're volunteers here, but this is like the problem at work that drives users up the wall, but that the developer refuse to acknowledge is even a problem. I'm a Windows programmer and know nothing of Mac widgets, or I'd work on this myself. Help, please, I'm begging someone.
I apologize for the double post, but I've found at least two workarounds!

Workaround 1:
1. Install Parallels Desktop 
2. Create a new Windows virtual machine
3. Install Firefox for Windows
4. Every time you want to add or remove a bookmark, fire up Firefox in Parallels and use *gasp* context menus to make the necessary changes
5. Export your bookmarks file from Windows to a shared folder
6. Open up Firefox for Mac, and import the bookmarks file

Workaround 2:
1. Create a del.icio.us account
2. When you find a new page to bookmark on your Mac, add the bookmark to del.icio.us
3. Buy a Dell
4. Every few months, peruse your del.icio.us account on your Dell and import bookmarks using *gasp* context menus
5. Export bookmarks.html from the Dell
6. Import bookmarks.html on the Mac

Let's close this bug... I think it's solved!

P.S. Great as Firefox is, bookmark management is basically unusable, especially on the Mac. If this is being pooh-poohed for 3.0, there better be some *huge* improvements in this area, or someone's head isn't screwed on straight in Mozilla.
What bothers me is that this bug is still considered an enhancement... and not basic functionality.

Maybe if there are a bunch of useless posts about this bug (such as this one), more people will find this bug. Not everyone knows that right-clicking on bookmark --> context menu.

Regardless, this bug reminds me of how spell-check does not work with All-in-One Gestures... where is the correlation? Is it the right-click to correct the spelling and make the gestures what causes the problem here?
Duplicate of this bug: 417158
Duplicate of this bug: 417570
Duplicate of this bug: 418149
Duplicate of this bug: 419374
Status: REOPENED → NEW
Component: Bookmarks → Places
QA Contact: bookmarks → places
Hardware: Macintosh → All
Duplicate of this bug: 420248
Duplicate of this bug: 422651
Duplicate of this bug: 424103
The functionality is the same in Camino - Version 1.6b3 (1.8.1.13 2008032420).

The interesting thing is the link doesn't open if you enable two finger tap -> right mouse click, because it's somehow differently received than a ctrl-click.  For example, I was unable to ctrl-click on a logmein.com session with my mom, but a right click via two finger tap worked fine.

Likewise, doing a two finger tap on an item in camino does nothing, it does not also fire a menu item command (per comment 1).  Perhaps we could meet at a halfway point?
As a former Windows user now running OS X I find this behavior annoying, but if the host OS treats right- or left-clicks on a menu item as identical actions how exactly is Firefox going to distinguish between the two? The Firefox team can't change the host OS. As much as it bothers me to have to do it, using the Bookmarks organizer via shift-command-B isn't that horrible an option. I think this sounds more like a "Can't Fix" than a WONTFIX, not unless Apple reconsiders their UI menu interaction decisions.
OS X has a secondary (or right) click. You can find these settings under the keyboard and mouse portion of the system preferences.
No ****. The problem is I cannot USE the right click on a bookmarks toolbar item in a subfolder. Two-finger click doesn't work probably by Cocoa's design, and control-click doesn't work because Firefox has built into it the action of control-click opening a link, even on Mac systems.
@ anderw.pennebaker@gmail.com: If you read the comment that I was replying to, you would see why that was relevant. I have been on this topic for quite a while now. It is very annoying that you cannot use the right click capability that the operating system offers. That was my point: the limiting factor is not the operating system, it is firefox. This is definitely a bug. Your frustration is shared here... trust me. 
Severity: enhancement → normal
Flags: wanted1.9.0.x?
Does it even make sense to have a popup menu for a menu? If instead of a platform-specific menu, bookmark toolbar folders displayed a XUL'd pane, it could be right-clickable on any OS. Is this a workable solution, or am I exhibiting a case of a little knowledge is a dangerous thing?
In the case shown before, I think it is a "what we are used to" situation. I can certainly say that having had this feature before, it hurts to not be able to manage my bookmarks via the right or secondary click in OS X. The difference lies in the fact that Mozilla is pursuing the Cocoa interface in OS X, which requires different libraries and coding from other user interfaces. In an ideal world, all user interfaces would share a common ground via standards like XUL, but unfortunately I am afraid they don't. Therefore, it is common to expect each user interface to encounter different issues at various stages of the development cycle. This is why open source development is costly and a genuine pain. Support is not just welcome, it is necessary.
We "simply" need to not use Cocoa widgets for the toolbar menu. Note the "simply" is in quotes. It's not impossible to fix... just no one wants to take the time to fix it.
"marking this as a WONFIX is about enough to finally, sadly, wean me away from using Firefox as my default browser"

Please no more comments like this here. There are other more productive ways to argue for the seriousness of a bug.

As for comment #25, Mike K, you're wasting my time because I have to read at least part of the worthless comment and I have to deal with the email. You're making me want to ignore you, neither one of us really wants that to happen.

"bookmark management is basically unusable"

This is a ridiculous statement. A little more perspective would go a long way.

"No shit"

Let's make better choices about language, Andrew. Immaturity doesn't make me want to read your comment. I actually stopped reading after the second word.

Let's stick to productive comments and avoid the need for me to write more comments like this that don't address the real issue here. I don't mean to come off as too much of a downer, I hope you listen to what I'm saying and keep contributing to our discussions!

Now, about this business of Cocoa widgets and interfaces, the only menus in Firefox that are actually Cocoa menu objects are the ones on the top of the screen. No menus that come out of a window in Firefox (like the bookmark toolbar or any context menus) are native Cocoa menu objects (NSMenu, NSMenuItem). In fact, we don't use any native cocoa controls in Gecko, with the exception of the menus on top of the screen. It is all XUL implemented via Cocoa and CoreGraphics rendering, windowing, and event handling. Even the native form controls are just visuals rendered into Gecko controls.

This isn't really the place to theorize about the ideals of cross-platform APIs, and if you want to call out problems in Mozilla with statements like "The difference lies in the fact that Mozilla is pursuing the Cocoa interface in OS X", please be more specific (even if what you said was true it is so vague it means nothing) and either do your homework or phrase it as a question. Questions and suggestions are welcome, vague unfounded statements don't help you or anyone else.
Josh,

I'm sorry you were offended. I think you can agree that this hasn't been addressed in two years, and there is some frustration. I obviously am not the only one who is frustrated. Firefox's interface is so incredibly good except for this one area. Some of us simply are not coders and are informing you of a bug. Mozilla responded by marking it a "WONFIX". After my rant and others', it was removed from WONFIX status. Then, it was marked as blocking 2.0, and on the eve of Firefox 2.0 coming out, its status was changed to an "enhancement request" setting off a new wave of frustration.

As you imply, this thread has become a bunch of us who don't really know where to start, whining about the interface. The reason this is so, is because the actual (volunteer) coders have all but ignored the thread. What else would it become? I can tell you that although the tone of #25 was extremely sarcastic, it accurately describes what I do; when I want to change a bookmark, I live with the outdated bookmark on my Mac, change it on my Dell, and every month or two I copy bookmarks.htm from the Dell. "Unusable" isn't the right word. "User-unfrendly" to the point that I go to another computer to make changes would be a better description. Bookmark manager improvements (which are sorely needed) are out of scope of this discussion.

If you want to ignore me, feel free, and that goes for anyone in the forum. This bug is the only one I subscribe to (it's the only shortcoming of Firefox I care about), and it's been ignored anyway, so it's not much of a loss.
I sincerely apologize for my comment. I am ashamed for having said it and wish Bugzilla would let me take it back. This is not a place to vent my frustration, it is a place to help developers improve their product. For all involved, I'm sorry and will not use Bugzilla as a complaint department again.
Josh, if you want to shut us up, fix the bug or provide input yourself on how to fix it so others can. If I could have fixed it, if I've ever programmed on a Macintosh in my life, I'd have done it years ago (about three years ago to be exact).

Coders need to stop thinking like coders for a moment (don't fix it because there's a really inconvenient "workaround") and start thinking like users. 13 votes and 15 duplicates for a Macintosh-only bug is pretty large.

The Bookmark management window has not changed all that much since Netscape 2.0. And it's not because it was "so good". The addition of context menus, along with extensions such as "Add Bookmark Here" extension is what makes bookmarks usable in Firefox for many users. On Macs, the former simply does not work, and there is no relevant extension.
Mike K:

While we all can understand your frustration (many of us have seen bugs take far longer to fix than we would like), your past couple responses have been inappropriate. Bugzilla is for addressing issues, and unhelpful comments make it harder for developers to address things, as they then must sift through noise to find the signal. This is unhelpful for all involved, and does nothing to resolve the issue.

Unfortunately, if you persist in this line of commenting, your account may be disabled. No one wants that to happen, as all volunteers can be helpful. Please review the Bugzilla etiquette guidelines https://bugzilla.mozilla.org/page.cgi?id=etiquette.html before commenting any further.

Thanks!
"Shut up, no one's going to work on this no matter how loud you scream." Heard you loud and clear. Go ahead and disable my account.
I'm sorry you took it that way. That wasn't what was said or meant, and sadly, I think you know that.
(In reply to comment #47)
> "Shut up, no one's going to work on this no matter how loud you scream." Heard
> you loud and clear. Go ahead and disable my account.
> 

Wow, drama queen much?  You're free to learn how to code and do it yourself.  What, too hard?  A lot of effort?  You think, somehow, that fixing this DOESN'T require effort from the people who contribute to this project?

Calm down.  I'll learn how to program and dedicate the patch for this to you, Mrs. Mike K. in her pretty little dress.

Disabling accounts is very rare, it is reserved for those who have decided that they don't want to be civil, and yet want to just annoy others with unhelpful drivel and hissy fits.  Why do you want to do that?  Feel free to go to the mozillazine forums and complain about how you were treated unfairly because _your_ bug wasn't fixed as fast as you'd like.  It's not wanted here, it's not needed here, and it's not helpful.  It doesn't aid your case, either.
Duplicate of this bug: 438021
Flags: blocking-firefox3.1?
Duplicate of this bug: 424059
Duplicate of this bug: 439275
Duplicate of this bug: 439275
Just adding myself to this conversation.  I was about to request this enhancement as well, but found this report in my search.  I would also appreciate if this was done.  Having bookmarks work one way on the toolbar and another way in folders on the toolbar is kinda ridiculous, imho, and I would like the Windows functionality to be preserved on Mac.  I like FFX enough to not threaten to switch (it's freeware anyway; who would care if I switch?), but I would really really appreciate if something was done about this.
Not wanted for 1.9.0.x. Note that this is how menus work on Mac. You're not supposed to be able to right/ctrl-click them.
Flags: wanted1.9.0.x? → wanted1.9.0.x-
"Note that this is how menus work on Mac. You're not
supposed to be able to right/ctrl-click them." 

...

" Contextual menus work just fine
elsewhere in Firefox:Mac, and it's a real pain to not be able to select an
alternate action from the bookmarks toolbar.

Especially when it "does" work in the bookmarks sidebar, which shows that it is
possible."

Try it: b

The bookmarks sidebar isn't a menu, it's a list.
Okay, so it is a list that happens to perform the exact same function as a menu... except it does it better. Personally, I want some more list-menu equality around here.
Not going to block on this, we need to figure out a real yes/no answer, but not for 3.1
Flags: blocking-firefox3.1? → blocking-firefox3.1-
IN regards to:
<#36: OS X has a secondary (or right) click. You can find these settings under the
keyboard and mouse portion of the system preferences.>
-> The setting is to select right/left button as primary button - nothing really to do with functionality
.
<#1: It was removed because right click in mac menus fires the menu item command
(just like left click).>
-> This is true ONLY of the Bookmarks menu, not the bookmarks toolbar (where right-click does NOTHING). And I'd like the choice to open in new window or new tab, new bookmark/folder/separator, cut , copy, properties,...
.
<#56: " Contextual menus work just fine
elsewhere in Firefox:Mac, and it's a real pain to not be able to select an
alternate action from the bookmarks toolbar.
.
Especially when it "does" work in the bookmarks sidebar, which shows that it is
possible.">
-> It's doable, so why not just do it and be done with it.
.
<#54: Just adding myself to this conversation.  I was about to request this
enhancement as well, but found this report in my search.  I would also
appreciate if this was done.  Having bookmarks work one way on the toolbar and
another way in folders on the toolbar is kinda ridiculous, imho, and I would
like the Windows functionality to be preserved on Mac.  I like FFX enough to
not threaten to switch (it's freeware anyway; who would care if I switch?), but
I would really really appreciate if something was done about this.>
-> DITTO!!
.
It seems that many people have expressed support for this both here and elsewhere, and understandably so.  Particularly those who have worked in both the Windows and Mac worlds.  I'm sympathetic to the plight of Mike K. as this seems to be less an issue of "getting around to it" and more of "we don't want to do it".
.
If I could cast all 1000 of my votes for this item (and see it fixed), I'd do it.  It is probably my biggest single issue of FFx on the Mac.
I came up with a temporary solution for "deleting" bookmarks. If you are like me, you actively add and remove/delete bookmarks (think shipment tracking information).

The easiest solution to get around the lack of the context menu and the ability to delete a bookmark is to add an extra folder in the bookmarks toolbar called "X" or ".". I keep mine on the far left where the smart bookmarks folder normally would appear.

When you are finished with the bookmark you can drag and drop it into this trash folder and then periodically clean it out. This method helps me reduce clutter and facilitates my organization scheme. 

I hope this temporary workaround helps reduce a few people's frustration regarding this bug.
Per comment 42, definitely seems like this is fixable. I'd accept a low-risk patch for this for a future release.

Regarding platformy-ness: true Mac users wouldn't even try opening a context menu on a menu, so will never know this exists. And the rest of you (Windows switchers to a one, I'll bet) will be happy.
Severity: normal → enhancement
Priority: -- → P4
Target Milestone: --- → Future
Duplicate of this bug: 470924
I am recently experiencing this problem today; I was able to right-click on the any bookmark on a list that results from clicking on a folder on my Bookmarks toolbar and it would give me the usual right-click options such as open in a new window, open in a new tab, etc.  Today I am unable to see those options.

However, the right-click options work when I do it on a link on a webpage.  It just doesn't work for the bookmarks or the RSS feeds.

Why is this happening just now when it was working fine before today?  I am using a Mac, which I just received on 3/31/09.
Duplicate of this bug: 384201
If the context menu can not be fixed easily, is it possible to add a functionality so that pressing "delete" (or ctrl+backspace) will delete a bookmark in a folder?

P.S. Daniel #61: A nice work-around.
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Flags: blocking-firefox3.6?
OK, so I am a Windows switcher. I was a good boy however, and read *all* the comments to this bug. It seems that complainers have been concentrating on the lack of ability to delete a bookmark from the bookmark menu. As far as I can tell, one can at least work around this by invoking the bookmark manager.

Unfortunately, I seem to have hit another manifestation where I'm unable to work out how to do what I want *without* the context menu that stubbornly does not appear:

To reproduce:

1. Create an RSS feed and hang it from a subfolder on your bookmarks toolbar.
2. Attempt to force a reload of the feed.

On Windows of course, this is easy: just right-click on the feed and select "reload bookmark." The situation where this behavior is desirable comes up regularly if one suspends and resumes often (eg) on a laptop, as it often takes a while before the feed updates after the network connection has been restored.

Is Firefox really saying to Mac users that if they want to be able to re-load an RSS feed it has to be on the top level of their bookmarks toolbar *and nowhere else*? Am I missing something and there's a good workaround / alternative way of invoking a reload? If there is, I'd love to hear it. Otherwise, please consider me one of the growing number of people clamoring for a fix for this.
Duplicate of this bug: 473028
Long standing bug, not going to block a short-turn release on it.

I do want to make it clear that drivers DO want to see this FIXED, despite any nay-saying that might have gone on previously. Show us a patch, please.
Flags: wanted-firefox3.6+
Flags: blocking-firefox3.6?
Flags: blocking-firefox3.6-
Duplicate of this bug: 420754
4 years and 2 months on... is there really any reason why this will not be done?! i thought the idea of cross-platform software was for it to be the same across platforms?! i'm a windows AND mac user and other than this the versions are the same from an end-user point of view - one of the reasons i stuck with firefox when i started using the mac.

admittedly there are more 'severe' bugs to be worked on first but after 4 years this still isn't resolved?! it does get rather annoying

MaFt
This really isn't right in terms of platform conventions.  Nominating for wontfix.
Whiteboard: wontfix?
(In reply to comment #72)
> This really isn't right in terms of platform conventions.  Nominating for
> wontfix.

see comment #62 and #69. let's stick to convention when it makes sense, not just for convention's sake.
Whiteboard: wontfix?
(In reply to comment #72)
> This really isn't right in terms of platform conventions.  Nominating for
> wontfix.

Well, if this is the case why is there even FireFox for Mac? Mac OSX ships with Safari - that is the conventional browser for Mac OSX so why change it? Ditto for Windows / IE.

As mentioned in comment #73 - "let's stick to convention when it makes sense, not
just for convention's sake"
Matthew, your comments here aren't productive. Please read up on bugzilla etiquette:

https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
Duplicate of this bug: 518206
If you're going to allow drag and drop reordering in the dropdown list, which isn't very "conventional" (Safari doesn't do it), then why not allow the context menu.  It's all about UI that saves time, isn't it?
Duplicate of this bug: 509926
I had https://bugzilla.mozilla.org/show_bug.cgi?id=527313 created and it (kind of) got marked a duplicated of this bug. I can't see the issue here, it can't be hard to implement when you already got context menus on some things? This is the only issue I have had with switching from Firefox on Windows to Mac.

Before letting this rest for another three years, can someone tell me why this hasn't always been included?
I'm new to Mac, but a longtime Firefox fan.  This issue is a pretty serious usability problem for me (it's even making me regret my switch to Mac, it's something I do every day, not having the option is a productivity drag).

I see this was brought up (here, at least) over 4 years ago.  Can we at least get any word on whether fixing it is (a) possible, and (b) being looked at?

Thanks!  Much appreciated.

Or, is there an add-on that can overcome this flaw without introducing other issues?  (Sorry if this isn't where to ask... just thought it'd be useful for folks who arrive here from Googling this problem.)
After reading the conversation here it seems some stubborn people who argue that this isn't "classic" Mac behaviour which is the problem.

Just like for the person above, this makes something as simple as deleting a bookmark a long process.

Of course, I can see why Windows gets priority, it does, after all have a huge market share, but is this really that hard to fix?
BTW, I respectfully yet strongly disagree with rating this bug as an "Enhancement" and just Priority 4. It should be labeled "Normal," just like the duplicate Bug 420754 (https://bugzilla.mozilla.org/show_bug.cgi?id=420754).

This is a normal function of Firefox in Windows, so it's clearly not a mere enhancement request. And it's not "Minor" either, since the workaround (opening and then navigating through Organize Bookmarks, making the change[s], then closing that window) is not nearly as easy, efficient, or
useful.

(If I vote for this, am I also agreeing with the Importance rating? Thanks for
kindly helping a newbie!)
As far as I know, if a bug gets enough votes, the importance level might rise since developers sees that people care about this bug and wants them to fix it.
Okay, thanks Magne. Duly voted.
That might work if you had hundreds of votes, but I've seen a number of comments from developers to the effect that votes normally mean absolutely nothing to them.

Nevertheless, both Dietrich and Beltzner said they want this to be fixed, and are willing to accept a patch. If nobody at Mozilla is taking the time to write one, perhaps one of us should step up to the plate?

Then again, if the priority were raised, it might garner the attention of someone more intimate with Firefox's inner workings...
Well, what would make votes effective is to create some sort of "highscore" list, where the unresolved bug with the highest amount of votes got the first place, but we're not here to discuss that now.

If I only knew the language used (C++?), I would write patches on my spare time, but I do not have the time to learn that. The only real programming language I know is Java, and I have very limited knowledge of that.

I just feel that this bug isn't getting the attention it should. I would even claim that it should get the status of breaking major functionality.

Maybe in three or four years, I will have the time to sit down and learn C++...
Please stop by adding more and more useless comments to that bug. Imagine that all the people in the cc list will be spammed with it. That way you will not get the attention to get it fixed. If you have a comment which will really help to fix that problem please go ahead. Otherwise create a forum or newsgroup thread or whatever else. Thanks!

(In reply to comment #62)
> Per comment 42, definitely seems like this is fixable. I'd accept a low-risk
> patch for this for a future release.
> 
> Regarding platformy-ness: true Mac users wouldn't even try opening a context
> menu on a menu, so will never know this exists. And the rest of you (Windows
> switchers to a one, I'll bet) will be happy.

What does UX think about?
Keywords: uiwanted
Maybe a solution:
if right click on a context menu doesn't work, than don't make a context menu of the drop down list.

The windows of the security and the bookmarks star, does they support a right click if this is enabled? Then use these in stead of the context menu's for the bookmarks.

If they don't is there a way to make a sort of container window where the bookmarks are displayed in if clicked on a bookmarks toolbar folder, and that enables a context menu?
(In reply to comment #88)
I'm not at all sure what Maaren is suggesting.  It reads to me that if you don't like the way it doesn't function, then do something else.  That isn't really an answer, there aren't really other options readily available, and this functionality already exists on the windows side.  Seems to me that since someone already coded it for windows, it should be very easy to implement.  And if some Mac user DOESN'T want to use it, then DON'T use it.  I've been a mac user a very long time, and as brilliant as Steve Jobs and Co are, the single-button mouse is annoyingly un-useful.  I've sought and used two button mice for many years going back to the early 90's, and think that this is one area where "having the option" is very usable.  I choose Firefix for my browsing in both the Mac and Windows envoronments, and it would be a great asset to see the functionality available on both products.  Maybe you can make it an option so users can switch it on.

Again - we burn a lot of time and energy by not attending to this feature which, for the person with the right programming skills, should be a very easy fix.

(In reply to comment #87)
I don't think that most of these comments are useless, but rather an expression of the frustration people have with the Mozilla community for not addressing this in a timely fashion.
Duplicate of this bug: 555862
Duplicate of this bug: 573971
Chrome allows the functionality mentioned in this bug.  Even safari gives users an easy way to manage items in a folder with their "manage contents" options when right clicking on a folder in the bookmark toolbar.  Maybe it is time to get this fixed.
A Partial Workaround:

  * Go to about:config in your browser
  * Search for the preference: ui.click_hold_context_menus
  * Set that to TRUE
  * Quit the Fox and restart
  * hold the click button in your desired RSS or bookmark

The problem is, it only works in bookmarks bar, not in the bookmarks menu.
Hope this helps.
(In reply to comment #93)
> A Partial Workaround:
> 
>   * Go to about:config in your browser
>   * Search for the preference: ui.click_hold_context_menus
>   * Set that to TRUE
>   * Quit the Fox and restart
>   * hold the click button in your desired RSS or bookmark
> 
> The problem is, it only works in bookmarks bar, not in the bookmarks menu.
> Hope this helps.

I forgot to say that you need to move the cursor before releasing the button or it will open the bookmark
(In reply to comment #93)
> A Partial Workaround:
> 
>   * Go to about:config in your browser
>   * Search for the preference: ui.click_hold_context_menus
>   * Set that to TRUE
>   * Quit the Fox and restart
>   * hold the click button in your desired RSS or bookmark
> 
> The problem is, it only works in bookmarks bar, not in the bookmarks menu.
> Hope this helps.

Rodrigo - I'm having trouble seeing how this applies to the issue - the display of "context menus" when right-clicking on a bookmark (want Mac version to work like Windows version).  I'm already set up like you describe and I'm not getting context menus.
(In reply to comment #92)
> Chrome allows the functionality mentioned in this bug.  Even safari gives users
> an easy way to manage items in a folder with their "manage contents" options
> when right clicking on a folder in the bookmark toolbar.  Maybe it is time to
> get this fixed.

Thanks, Eric.  However, the options available (only on the toolbar folder, not in dropdowns) don't begin to compare to a real contextual menu at the bookmark level.
(In reply to comment #95)
> (In reply to comment #93)
> > A Partial Workaround:
> > 
> >   * Go to about:config in your browser
> >   * Search for the preference: ui.click_hold_context_menus
> >   * Set that to TRUE
> >   * Quit the Fox and restart
> >   * hold the click button in your desired RSS or bookmark
> > 
> > The problem is, it only works in bookmarks bar, not in the bookmarks menu.
> > Hope this helps.
> 
> Rodrigo - I'm having trouble seeing how this applies to the issue - the display
> of "context menus" when right-clicking on a bookmark (want Mac version to work
> like Windows version).  I'm already set up like you describe and I'm not
> getting context menus.

Sorry for not explaining correctly.
The method I described allows you to show the "context menu" in nested submenus inside the bookmarks toolbar only. Not by right-clicking, but holding the left click. far from ideal, but useful.
Rodrigo - Thanks.  That helps a lot in providing the functionality, although I think that it is preferable to have both Win/Mac versions work the same.  A big factor for me in choosing Firefox was to have the same software on both platforms.  I'll have to remember click-n-hold.
Duplicate of this bug: 605818
I also really want the Win/Mac versions to work the same.  How about getting this issue fixed in 4.0? I get tired of having to open "Organize Bookmarks" and going through the folders to a bookmark to be able to use a 'right click' function.  If it can work in there, why so difficult to write it in for the toolbar drop downs?
(In reply to comment #100)
@ Shimerazcatx:
>If it can work in there, why so difficult to write it in for the toolbar drop downs?

You SHOULD read the comments above. A context click in a context menu is not supported on mac.

And everybody is tired. Of reading this bug with so a lots of comments, that even don't help to fix it.
(In reply to comment #101)
> (In reply to comment #100)
> @ Shimerazcatx:
> >If it can work in there, why so difficult to write it in for the toolbar drop downs?
> 
> You SHOULD read the comments above. A context click in a context menu is not
> supported on mac.
> 
> And everybody is tired. Of reading this bug with so a lots of comments, that
> even don't help to fix it.

<Raises hand> I am not tired of people complaining about this bug; I am tired of this bug not being fixed.

Shimerazcatx's post reminded to give beta-feedback for why "Firefox has made me sad.."

@Shimerazcatx's, ff4.0beta7 does not have the fix yet; sorry. Maybe they will fix it on the 6 year anniversary or in ff6.0.
(In reply to comment #102)
> (In reply to comment #101)
> > (In reply to comment #100)
> > @ Shimerazcatx:
> > >If it can work in there, why so difficult to write it in for the toolbar drop downs?
> > 
> > And everybody is tired. Of reading this bug with so a lots of comments, that
> > even don't help to fix it.
> 
> <Raises hand> I am not tired of people complaining about this bug; I am tired
> of this bug not being fixed.

<Raises hand> Me too

In any case I've decided to try another browser, there are too many little annoyances like this building up in Firefox.
Duplicate of this bug: 647097
Again, I'd vote all 1000 votes to addressing the 'no context menu' in Bookmarks.  I am looking at every other browser available for MacOSX to see if someone of them will get this functionality worked into a release.  I use both windows and Mac computers and this lack of functionality in Mac is VERY frustrating.  I'm puzzled as to why it has not been addressed long ago!
Duplicate of this bug: 688457
OK now, I'm sorry to bug the cc'ers and the deveopers (as a fresh Mac-user who is pretty frustrated for witnessing all the stuff Mac isn't capable of (like not being able to shift-del) for some reason); but I have totally read every comment and all the arguments on this topic and really would simply like to know, after 6 years of status quo, if the non-solved presence of this "bug" is due to the very nature of the Mac OS or not.

I mean, if this is not going to be solved forever just because Mac-lover coders (please, just a joke! (= ) don't want it to (due to the principle of right-click-absence and trying to apply it whenever and wherever they can) or actually Mac won't let it to, please would somebody capable or who has the knowledge, at least let us know, so that we try to focus on a workaround for this and get used to it for the rest of our Mac-life and live on?

Thanks a thousands.
However, Google Chrome, it's possible... screenshot: https://i.minus.com/ifa5Xh4ZjRfXp.png
Duplicate of this bug: 610908
Hi,

This has been "bugging" me for a while now :-) In several different versions of Firefox and OS X I have come across this issue. A bookmark on its own in the toolbar is easily configurable, but if I drag it into a folder the context (right click) menu is no longer available.

Working on a web platform, is is very nice (if not imperative) to be able to move freely between Windows and OS X. I use the context menu quite a bit - mainly to assign one letter keywords to oft-used bookmarks so I can just hit ctrl-l then the keyword to navigate to the uri.

Thanks to all who help bring Firefox to the world!
Colin
I am newly a Mac user and have been greatly frustrated by this in the short time already. To find that it has not been fixed in 7 years is disheartening. At least I found the `ui.click_hold_context_menus` workaround and it works perfectly. I did not even have to restart Firefox. I just set the preference, clicked and held on a bookmark inside a folder on the bookmark toolbar, and bingo, there comes the context menu I was looking for. But the fact that this workaround exists makes the persistence of the open bug particularly baffling:

Firefox already can *and already DOES* display the context menu in question!

Very evidently, fixing this bug is *not* a question of whether it can technically be done: it already *is* done. The only issue is why Firefox won’t also pop up this self-same already-working context menu on control-click, without a need for the workaround.
very annoying indeed. please fix this, it's been 7 years...
Please fix this bug. I recently switched from PC to Mac at home, and this is one of the only daily annoyances I still have.

I have also been using the "ui.click_hold_context_menus" work-around for the time being, but it adds an extra level of unwanted functionality. If you left-click OR right-click and hold anywhere in Firefox, even on webpages, the UI comes up. This has been annoying in many situations.

I can't imagine this fix taking longer than half a day for one developer to include into the next revision of Firefox.

PLEASE reconsider fixing this bug, lots of us would appreciate it. :)

Thanks,
Tim
There is nothing to reconsider actually, we are fine with adding context menus, provided someone finds resources to actually make a patch.
(In reply to Karsten Schramm from comment #9)
> If this bug is not fixed, the bookmark toolbar behaves inconsistent. One
> cannot have a context menu on top level entries but not on drop-down entries.
> 
> Please re-open this bug.

I agree with this remark. this bugg appears in safari and firefox and it really is not practical to not be able to edit bookmarks directly with right click.
See Also: → 632272
Is Bug 564339 a duplicate of this bug? It refers to the bookmarks overflow rather than to folders in the bookmarks toolbar; are they in the same vein?
Duplicate of this bug: 564339
Duplicate of this bug: 834870
It's funny that dupes for this bug are still popping up 8 years later.  You think someone would have fixed this by now (If I had the skills, I would have).  I stopped using firefox because of this one incredibly annoying bug and couldn't be happier with chrome.
Can you please fix this bug, this is really annoying for osx users.

Thanks
I guess that we can fix this bug now easily.

However, in bug 503639, context menu on bookmark folder was disabled intentionally. The reason is "It's not Mac OS X UI behavior".

On Chrome for Mac, context menu is available on bookmark toolbar's folder. So, I don't think that the reason of fixing bug 503639 is not good.

Smaug, Enn and Steven, how do you think about this?

FYI: This bug was created by bug 327036 because they couldn't fix the buggy behavior on Mac at Fx2.
Flags: needinfo?(smichaud)
Flags: needinfo?(enndeakin)
Flags: needinfo?(bugs)
> I guess that we can fix this bug now easily.

Why do you think so?  Right-clicking (or ctrl-clicking) on a menu item isn't supported by the OS -- when you do that you select the item.  Since our context menus are non-native, we *could* do it.  But since it goes against the grain, it might be quite a lot of work to do it right.  And, quite frankly, I don't think this feature is important (or desirable) enough to spend a lot of time on.

But if you (or someone else) can find an easy way to do this, it might be worthwhile.

By the way, does anyone know of any app on OS X that behaves intelligently when you right-click on a menu item?
Flags: needinfo?(smichaud)
Please refer to comment #62 and comment #69. It doesn't matter whether the behavior is platform-standard (which has already been discussed ad nauseam); in response to user demand, drivers have said they want this fixed.
I don't have strong feelings about this.
Fixing this would be against OS conventions but if context menus are useful for the users, perhaps
context menus should be supported after all.
(I wonder why OSX has such convention.)
Flags: needinfo?(bugs)
(In reply to Steven Michaud from comment #122)
> By the way, does anyone know of any app on OS X that behaves intelligently
> when you right-click on a menu item?

Chrome does it. Right-click on menu item from a folder in the bookmarks toolbar and you get the context menu.

MaFt
Thank you, Smaug, Steven and Matthew.

(In reply to Steven Michaud from comment #122)
> > I guess that we can fix this bug now easily.
> 
> Why do you think so?  Right-clicking (or ctrl-clicking) on a menu item isn't
> supported by the OS -- when you do that you select the item.  Since our
> context menus are non-native, we *could* do it.

This bug is opened for in bookmark toolbar's menu, not in the native menubar's "Bookmark" sub menus. And I can right click there, therefore, I guess we can fix this easy.

Additionally, this behavior is not native behavior on other OSes too (Also IE has it, but it's not native menu). Therefore, I think that it doesn't make sense using native behavior for the reason whether this should be fixed or not.

>  But since it goes against
> the grain, it might be quite a lot of work to do it right.  And, quite
> frankly, I don't think this feature is important (or desirable) enough to
> spend a lot of time on.

If you talk about native menu's "Bookmark", I agree with you.

> By the way, does anyone know of any app on OS X that behaves intelligently
> when you right-click on a menu item?

As I and Matthew said, Chrome for Mac has this feature.
Flags: needinfo?(smichaud)
As comment 111 says above, this behavior is already there with a slight hack.  It's not perfect but the expected menu shows so I would think getting it to show on a right click would be easy enough.
Tired of hearing from excuses like these: in OS X we should blah blah blah... or we already have a workaround that blah blah blah...

In a word, users need this feature. Period. We don't need more comments here saying that fix on this is worthless and offering no help in the same time.

(In reply to Eric Johnson from comment #127)
> As comment 111 says above, this behavior is already there with a slight
> hack.  It's not perfect but the expected menu shows so I would think getting
> it to show on a right click would be easy enough.

(In reply to Steven Michaud from comment #122)
> > I guess that we can fix this bug now easily.
> 
> Why do you think so?  Right-clicking (or ctrl-clicking) on a menu item isn't
> supported by the OS -- when you do that you select the item.  Since our
> context menus are non-native, we *could* do it.  But since it goes against
> the grain, it might be quite a lot of work to do it right.  And, quite
> frankly, I don't think this feature is important (or desirable) enough to
> spend a lot of time on.
> 
> But if you (or someone else) can find an easy way to do this, it might be
> worthwhile.
> 
> By the way, does anyone know of any app on OS X that behaves intelligently
> when you right-click on a menu item?
Whiteboard: [parity-Chrome]
Comment on attachment 8335074 [details] [diff] [review]
part.1 Specify context menu for bookmark items to bookmark toolbar items

Just removing Mac specific code and #ifndef XP_MACOSX.
Attachment #8335074 - Flags: review?(enndeakin)
Comment on attachment 8335156 [details] [diff] [review]
part.2 PresShell should allow to open context menu even on XUL menu on Mac

Removing the popup checker for context menu event.
Attachment #8335156 - Flags: review?(enndeakin)
Attachment #8335156 - Flags: review?(bugs)
Cancelling needsinfo? of Enn since I requested review of the patches to him.
Flags: needinfo?(enndeakin)
Wow, can't believe after 8 years some one is actually fixing this,
i'm hoping some one would fix this bug (which is there for +9 years) too 
https://bugzilla.mozilla.org/show_bug.cgi?id=237623

Thank you Mr Nakano
(In reply to comment #126)

I'm not opposed to fixing this bug, and I'm certainly not against violating OS X conventions -- if that makes sense and can be done easily.  My concern was that, just because it violates OS X conventions, implementing it might be difficult, and that fixing this bug isn't worth a lot of trouble.

Now it seems this bug will be quite easy to fix.  As long as that remains so, I'd say go for it.
Flags: needinfo?(smichaud)
I can't speak for everyone, but I think this bug is worth "a lot of trouble."  I stopped using FF as my primary browser because this drove me nuts.  I put the majority of my bookmarks into folders and not being able to right click them without a menu hack or going into the bookmark manager is a constant source of frustration.
(In reply to Eric Johnson from comment #137)
> I can't speak for everyone, but I think this bug is worth "a lot of
> trouble."  I stopped using FF as my primary browser because this drove me
> nuts.

Same here. I used Firefox as my primary browser from 2004 until earlier this year (almost a decade!) because of a tiny handful of highly requested issues like this that were ignored. We are power users who frequently use bookmarks. I switched over from PC to Mac, and basically couldn't use bookmarks anymore. The hackly left-click-and-hold solution is not really usable long term.

Many thanks for the recent uproar on this issue. Really hopeful to see it working soon. Best of luck Masayuki! :)
Attachment #8335156 - Flags: review?(bugs) → review+
Attachment #8335074 - Flags: review?(enndeakin) → review+
Attachment #8335156 - Flags: review?(enndeakin) → review+
https://hg.mozilla.org/mozilla-central/rev/1c77baa4ac3e
https://hg.mozilla.org/mozilla-central/rev/94f742b1da8c
Status: ASSIGNED → RESOLVED
Closed: 16 years ago8 years ago
Resolution: --- → FIXED
As another person who subscribed to this bug and quit using Firefox for years because of it... you are THE BEST. Thank you!
Hi so is this bugfix being implemented anytime soon or how would i fix this using the files attached?
Hi,
this bugfix has been implemented for some time now. But you have to try the Firefox Nightly to see it. Guess the fix is coming to the "regular" Firefox within some weeks...
Thank You! Thank you! Thank you! It took more than 8 years but i really start to cry tears of joy ! 

Happy X-Mas thanks for that present,
Sascha

PS. If now the self certification (permanent allowance) bug is solved i will be in heaven !
Target Milestone: Future → Firefox 28
So we are expecting...after many years, a fix for the fact that when you right click a bookmark within a folder on the toolbar menu that NO menu comes up that enables you to delete it?  If so, I'm just stunned that this is FINALLY being addressed.  This drove me to Chrome (which has its own issues).  I don't guess anyone has a timetable for this?
(In reply to Mike N from comment #145)
> So we are expecting...after many years, a fix for the fact that when you
> right click a bookmark within a folder on the toolbar menu that NO menu
> comes up that enables you to delete it?  If so, I'm just stunned that this
> is FINALLY being addressed.  This drove me to Chrome (which has its own
> issues).  I don't guess anyone has a timetable for this?

The Target Milestone is Firefox 28, for channel's release schedule, see https://wiki.mozilla.org/RapidRelease/Calendar
Thank you SO much for that quick reply.  Perhaps our long national nightmare <grin> is about over!
Hi Mike,

not yet, there still a annoying Bug open: self certification (permanent allowance) bug.In our days we lost the ability to perfect things, especially since we have controllers....
Still wishin' and hopin' for good news for us OSX right clickers on Firefox 28!  :)
Keywords: verifyme
Verified as fixed on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:28.0) Gecko/20100101 Firefox/28.0 (20140210161136)
Status: RESOLVED → VERIFIED
Keywords: verifyme
relnote-firefox: --- → ?
@José, Could you argue why you should it should be part of the release notes? That sounds a minor feature to me.
Just downloaded beta version 28.0.  The right click appears to work perfectly.  MANY THANKS!  

Mike N.
@Sylvestre, if you read the blog you should be aware that this is not a minor bug since 2005 (!). It was a major defect in the ability to have the same UI experience or better ergonomic handling on all plattforms. Therefore it shhould be mentioned.
Great fix, but doesn't merit being in the release notes as it's for a small population and had workaround.
Let's see...an eight year old bug that crippled the second largest browser on the OSX platform...naw, no reason at all to work on that or include it in a release.

May YOUR next maddening bug go unfixed for eight years.  After all, it's only for a "small population".
I strongly disagree that it shouldn't be in the release notes. Let people know! This is an important fix for power users of bookmarks.

Firefox was great on Windows, but when I switched to Mac about 2 years ago, this bug literally made me switch from Firefox to Chrome because it was left alone for too long. Also the temporary fix was slow, and often resulted in unwanted actions. I wouldn't consider it a workaround at all with how many problems it had. Power users of bookmarks noticed this, and it was indeed crippling.

Anyways, thanks for adding the feature in! I still use Firefox a few times as week, and this feature won't go unnoticed. :)

Special thanks to Masayuki Nakano for making this happen!!
It's IN the release notes. Click the link that says "view all changes"

Any way to lock this thread now?
While I sympathize with your passion, not every fix may make the release notes, for obvious reasons. It's great this has been fixed, there are hundreds of other great fixes in each release that don't make the notes.
The best thank you you can give to developers is just to enjoy browsing the web with Firefox.

Now, please let this bug sleep. There are many people cc-ed here and any further comment is just going to nag everyone.
Duplicate of this bug: 984152
You need to log in before you can comment on or make changes to this bug.