Closed Bug 300734 Opened 19 years ago Closed 19 years ago

wrong table alignment

Categories

(Core :: Layout: Tables, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: wolfiR, Assigned: bernd_mozilla)

References

()

Details

Attachments

(1 file)

The innermost table on the above page (starting with "Homepage eröffnet") is
aligned centered while it should be left.
Konqueror, Firefox 1.0.x, IE6 do all align it left.
The page is standards mode. The problem is that <div align="center"> sets its
text-align to -moz-center which gets inherited all the way down through the
tables (because quirks.css is not applied).

In standards mode, shouldn't <div align="center"> set text-align to "center",
instead?
No, in standards mode <div align="center"></div> still needs to center blocks.

Presumably this was broken by bug 273857.  I never really thought the change was
correct (see bug 273857 comment 11), but was told it matched WinIE6.
(In reply to comment #1)
> The page is standards mode. [...]

Not in IE6, which explains the difference.
I saved the URL locally and changed the first line to read:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Strict//EN">

and then IE6 renders it in "CSS1Compat" mode and the layout matches ours.
It seems it is the <?xml version="1.0" encoding="iso-8859-1"?>
that triggers "BackCompat" mode in IE6.
In any case, I don't see any reason to break the traditional HTML behavior in
standards mode, even if IE6 does.
If you can give a good reason to invalidate the bugs that we will have when we
revert the standards behaviour to the broken one, its fine with me, its a loose
loose situation anyway.
What bugs?  There aren't any relevant specifications.  It's just a disagreement
with WinIE6 in standards mode, but only in a place where WinIE6 in standards
mode disagrees with pretty much everything else.
I personally liked the idea to get rid of this quirk, but its fine with me to
backout bug 273857 and tell the world that we don't know what drives IE.
Assignee: roc → nobody
Component: Layout → Layout: Tables
QA Contact: layout → layout.tables
Assignee: nobody → bernd_mozilla
Attached patch backoutSplinter Review
Attachment #189417 - Flags: superreview?(dbaron)
Attachment #189417 - Flags: review?(dbaron)
Attachment #189417 - Flags: superreview?(dbaron)
Attachment #189417 - Flags: superreview+
Attachment #189417 - Flags: review?(dbaron)
Attachment #189417 - Flags: review+
Comment on attachment 189417 [details] [diff] [review]
backout

see comment 4, this reverts  a decision which created more trouble than it is
worth.
Attachment #189417 - Flags: approval1.8b4?
Comment on attachment 189417 [details] [diff] [review]
backout

see comment 4, this reverts  a decision which created more trouble than it is
worth.
Attachment #189417 - Flags: approval1.8b4?
Attachment #189417 - Flags: approval1.8b4? → approval1.8b4+
fix checked in
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
*** Bug 276466 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: