Cursor flickers when double click is "spread" in URL bar

VERIFIED INVALID

Status

()

Core
Editor
P3
trivial
VERIFIED INVALID
19 years ago
17 years ago

People

(Reporter: Mitja, Assigned: mjudge)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Copying with CTRL-C seems to copy an empty string to clipboard. Paste works like 
normal. This problem somehow disappeared for the moment but definitely existed 
for few runs after DL-ing M14.
(Reporter)

Updated

19 years ago
Summary: CTRL-C in Location bar sometimes is not working in M14 → CTRL-C in Location bar sometimes is not working in M14
(Reporter)

Comment 1

19 years ago
Did some more checking. After clicking in window showing html, copying does not 
work anymore. For now I could reproduce it if local file is loaded. Also it 
seems that cursor when setting focus is always set initially at beginning and 
only after at mouse position.

Comment 2

19 years ago
This sounds like a duplicate of 29004, which has been fixed in M15. I'd suggest
checking in an M15 build if you'd like to be sure.
Mitja@zejn.si - given elig's comments, are you still seeing this problem with 
recent builds of Mozilla?

Gerv
(Reporter)

Comment 4

19 years ago
Checked it. The copying bug is definitely fixed.
The flickering of cursor however is not fixed. I do not know if this is 
considered as bug or feature.

The action to reproduce it: make a double click with first click on different 
position then the second. You will notice cursor briefly showing at begining of 
edit box.
Yep, I do see that. Rewriting summary and downgrading to Trivial.

Gerv
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: CTRL-C in Location bar sometimes is not working in M14 → Cursor flickers when double click is "spread" in URL bar

Comment 6

18 years ago
I guess I'm not sure this is really a bug.  Looking around in Windows it seems 
to be common practice that in the middle of a doubleclick you first do that 
action associated with the single click.  That's all this is.

But I just deliver the events so I'll let the person who does cursor control 
make the final call on this one.  I believe that is mjudge.
Assignee: joki → mjudge

Comment 7

18 years ago
I agree with joki.  I am assuming his interpretation is correct so I am going to 
resolve this bug as INVALID (since we want it to work that way).  

Mitja or others--if you are seeing a different flickering, please reopen.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Component: Event Handling → Editor
Resolution: --- → INVALID
Target Milestone: --- → M16
(Reporter)

Comment 8

18 years ago
I still think it is a bug. This sort of behaviour is not seen elsewhere 
(Netscape 4.7, Windows Start-Run, ...). Double click is usually a special 
message and is not the same as click (AFAIK).

Comment 9

18 years ago
Works for Me
Platform: PC
OS: Windows 98
Build # 2000100508 M18 Trunk Build
Marking as Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.