cursor focus position lost when I use go back or forward in history

VERIFIED DUPLICATE of bug 36539

Status

()

defect
VERIFIED DUPLICATE of bug 36539
14 years ago
14 years ago

People

(Reporter: jsmith1111111111, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Suppose I am using the tab key to navigate links on a page. I reach one I am
interested in, and press enter to follow it. Then I change my mind, I don't want
to be on this new page, so I press the back button (or ALT+left arrow) to get
back to where I was. Unfortunately, the focus (i.e. the link that I selected,
the one that was "highlighted") no longer has the focus. If I press tab to
continue jumping through the links on the page, I find myself always starting at
the top.

Is it possible to have firefox remember (and return to) where the focus was on a
page I go back to with the back button (and the go forward with the forward
button as well).

Reproducible: Always

Steps to Reproduce:
1. go to a web site
2. press tab several times to get to a link
3. press enter
4. press the back button (or ALT+left arrow)
5. press tab to "continue" navigating through the links

Actual Results:  
focus returns to top of page

Expected Results:  
focus returns to previous position

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 36539 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 36539 ***
Status: VERIFIED → RESOLVED
Closed: 14 years ago14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.