If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

browser.tabs.opentabfor.windowopen = true not working

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Sebastian Brand, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

It seems that browser.tabs.opentabfor.windowopen has no effect. See Reproduce below

Reproducible: Always

Steps to Reproduce:
0. Have browser.tabs.opentabfor.windowopen = true
1. go to www.linux.org
2. Click on the link for "LinuxHQ" at the bottom of the page

Actual Results:  
A new window is opened

Expected Results:  
A new tab should have been created

Am I too stupid?

Comment 1

12 years ago
I have browser.link.open_newwindow = 3 instead, that seems to work...
I don't think anyone reads the pref you're trying to use.

See also: http://www.mozilla.org/support/firefox/tips#beh_tabbedbrowsingoptions
which does tell you how to get the behaviour you want.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050713
Firefox/1.0+

Marking invalid based on the fact that the pref doesn't actually exist :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.