Closed Bug 300775 Opened 16 years ago Closed 16 years ago

Status of last "active tab" carries over to all tabs

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 104532

People

(Reporter: tracy, Unassigned)

Details

seen on Windows, Mac and linux trunk builds.
related or dupe bugs 275284 and 300361

steps to reproduce:
-Open a page (ensure the status goes to "Done") - Tab 1
-Open a page in a new tab (also ensure the status goes to "Done") - Tab 2
-Then open a slightly slow loading page (www.apple.com), but click the stop
button before the page finishes loading.  You should now have "Stopped" in the
status bar. (or Waiting for... , which is probably another bug) - Tab 3
-Next, click on Tab 2 and then Tab 1

tested results:
The status of tab 3, "Stopped"  is displayed for each Tab 1 and Tab 2. 

expected results:
Tab 1 and Tab 2 should display "Done"

Then:
-Reload Tab 1 (ensure the status goes to "Done")
-Click on Tab 2 and then Tab 3

tested results:
The status of tab 1, "Done"  is displayed for each Tab 2 and Tab 3. 

expected results:
Tab 2 should display "Done" and Tab 3 should display "Stopped" (or Waiting
for..., whatever it was left as) 

The general expectation is that each tab retains/displays its own true status
when switchign from tab to tab.
Flags: blocking-aviary1.1?

*** This bug has been marked as a duplicate of 104532 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
Flags: blocking-aviary1.1?
You need to log in before you can comment on or make changes to this bug.