Option to identify responsible changer in email header

RESOLVED DUPLICATE of bug 126151

Status

()

Bugzilla
Email Notifications
--
enhancement
RESOLVED DUPLICATE of bug 126151
13 years ago
13 years ago

People

(Reporter: Bevan Bennett, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4
Build Identifier: 

We use bugzilla internally and many people get swamped with bug change
notifications (ones that they want to see). 

We wanted to be able to add something to the "From:" header so that the
recipient can easily tell whom was responsible for generating that particular
notification (knowing who spawned the message can often inform you of whether
it's an important comment or not, without having to open up the message or go to
bugzilla).

This turned out to be a fairly easy thing to accomplish, so I offer the changes
back as a potential enhancement.

Reproducible: Always

Steps to Reproduce:
1. create or change a bug
2. look at the generated email
3. "From: Bugzilla <bugzilla-daemon>"
Actual Results:  
No Bugzilla header indicates what user was responsible for the email.

Expected Results:  
"From: Bugzilla from Bevan Bennett <bugzilla-daemon>" [if realname set]
"From: Bugzilla from bevan@fulcrummicro.com <bugzilla-daemon>" [if realname not set]

The newchanged email profile can now make use of the %fromwho% variable which
contains " from realname" if a realname exists, " from email address" if there
is no real name, or is empty if a value could not be determined.
I then change the newchanged profile to start with "From: Bugzilla%fromwho%
<bugzilla-daemon>", in order to take advantage of the new feature.
(Reporter)

Comment 1

13 years ago
Created attachment 189325 [details] [diff] [review]
Adds %fromwho% template variable (vs 2.18.3)
(Reporter)

Updated

13 years ago
Attachment #189325 - Attachment description: Adds %fromwho% variable for use in email templates → Adds %fromwho% template variable (vs 2.18.3)

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 126151 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.