Last Comment Bug 300849 - [FIX]IFRAME removed during its own onload event never turns off tabspinner
: [FIX]IFRAME removed during its own onload event never turns off tabspinner
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: mozilla1.9alpha1
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
: Hixie (not reading bugmail)
Mentors:
: 305471 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-14 16:43 PDT by Taral
Modified: 2005-11-05 09:09 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase (331 bytes, text/html)
2005-07-14 16:44 PDT, Taral
no flags Details
Like so, say (1.31 KB, patch)
2005-10-31 21:24 PST, Boris Zbarsky [:bz] (still a bit busy)
darin.moz: review+
jst: superreview+
Details | Diff | Splinter Review

Description Taral 2005-07-14 16:43:55 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050630 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050630 Firefox/1.0+

If an IFRAME is removed during its own load event, the tabspinner will run forever.

Reproducible: Always

Steps to Reproduce:
Comment 1 Taral 2005-07-14 16:44:54 PDT
Created attachment 189367 [details]
Testcase

Honestly, the tabspinner should stop as soon as the IFRAME is removed.
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2005-08-21 17:39:19 PDT
Sounds like we remove ourselves from the docloader tree before we get a chance
to notify our parent... Should we save the parent ptr before firing onload or
something?
Comment 3 Jesse Ruderman 2005-08-22 13:40:14 PDT
*** Bug 305471 has been marked as a duplicate of this bug. ***
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2005-10-31 21:24:05 PST
Created attachment 201489 [details] [diff] [review]
Like so, say
Comment 5 Johnny Stenback (:jst, jst@mozilla.com) 2005-11-01 17:28:06 PST
Comment on attachment 201489 [details] [diff] [review]
Like so, say

sr=jst
Comment 6 Boris Zbarsky [:bz] (still a bit busy) 2005-11-04 19:06:28 PST
Fixed on trunk.

Note You need to log in before you can comment on or make changes to this bug.