Check for updates gives a "AUS: Update XML file not found (404)"

VERIFIED DUPLICATE of bug 299482

Status

()

VERIFIED DUPLICATE of bug 299482
13 years ago
10 years ago

People

(Reporter: ajay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

Using the "Help - check for updates" link in Deer Alpha 2 gives a "AUS: Update
XML file not found (404)" error. Clicking on the "http://www.mozilla.org/update"
link provided below opens up a "403: Access forbidden" page on mozilla.org

Probably the XML file the link is looking for is missing from whichever server
Deer Park is trying to contact. And link to mozilla update page is broken

It is a ugly message to get even for a Alpha version, a "There are no updates
available" or a similar message would be better. How about asking Deer Alpha to
check out other mirrors if it fails to find the file in the default mirror,
(Helps a lot if a mirror is down). 

Getting the same mesage in Firefox 1.1 is sure to **** of a few users, which is
not what we want (atleast I dont want). 

I am filing this bug from Deer Alpha 2, so the proxies are okay

PS: Deer Alpha 2, is really fast (at least for startup and fasttrack...) Nice
work :) 

Reproducible: Always

Steps to Reproduce:
1.Open Deer Alpha 2 
2.Click on "Help-> Check for updates"
3.You should see "AUS: Update XML file not found (404)" error (Sitting in India)
4.Clicking on the link below in the same error screen
"http://www.mozilla.org/update" opens up a "403: Access forbidden" page


Expected Results:  
Give a nicer "No updates available at the moment" or similar message
I also see this on WinXP. Confirming, and changing OS to All.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
There's a reason it's being called an alpha release ;)
The update system isn't completely ready yet. If you want to use it with DPa2,
enter the following value for app.update.url in about:config:
https://aus-staging.mozilla.org:8711/update2/0/%PRODUCT%/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/update.xml

Recommend change to INVA
Agreed.

<- INVALID
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Reopen to dupe
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 299482 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.