If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

removing 127.0.0.1 from the list of proxy exclusions causes references to that IP to be relative to the proxy-server

RESOLVED WONTFIX

Status

()

Firefox
Preferences
--
enhancement
RESOLVED WONTFIX
12 years ago
9 years ago

People

(Reporter: Richard Duran, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 10/09, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

I never really understood why default profiles always included 127.0.0.1 and
localhost in the list of proxy exclusions. Then I found out  from one of our
users that http://127.0.0.1/ brought up a page they weren't expecting, which in
fact turned out to be the root page of our proxy-server.

I don't know if this is intentional, but if it _is_, what is the reasoning for
this? It would be nice if a user was able to enable/disable local intranet
addresses from being accessed via the proxy using a checkbox, rather than having
to explicitly list "localhost, 127.0.0.1, 192.168.1.0/24, 10.0.0.0/8".

Reproducible: Always

Steps to Reproduce:
1. Remove 127.0.0.1 from list of proxy exclusions
2. Make sure browser is set up to use a proxy
3. Make sure proxy is serving web pages
4. Set URL to http://127.0.0.1/
Actual Results:  
Loaded web page being served by proxy server

Expected Results:  
Load web page being served by local host.
If you remove the localhost from the no-proxy list, then it's clear that the
proxy is asked for 127.0.0.1.
A checkbox wouldn't work because on my intranet you need the proxy for
10.0.0.0/8 but of course not for the localhost.

Comment 2

10 years ago
Can we now close the bug because of comment #1?
Whiteboard: CLOSEME 10/09

Comment 3

9 years ago
Richard: 

see bug 31510... basically we didn't want to hard code the exclusion of localhost + 127.0.0.1, and we didn't want to keep adding esoteric switches to the manual proxy dialog, which had enough issues...

There are people that need to proxy localhost, most of them know what they are doing, so they could remove it...

I think this is the first time I've heard of pilot error where a user removed this to surf to the proxy page. (BTW, you should probably fix that, you probably shouldn't proxy your own local interface on the server).

I doubt we'd remove this, in fact, we probably should expand the exclusion to 127.0.0.0/8, but that might make less sense to people (visually).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.