Closed Bug 300944 Opened 17 years ago Closed 17 years ago

Frameset page shows up blank when going back/forward in history with bfcache on

Categories

(Core :: DOM: Navigation, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Unassigned)

References

Details

(Keywords: regression, testcase, top100)

Attachments

(1 file)

See upcoming testcase.

To reproduce:
- Visit testcase, you see some text in the top and bottom frame.
- Go back
- Go forward

Result:
The frameset page doesn't show the text in the frames.
This is a regression.
It works in the 2005-07-14 build, but not in the 2005-07-15 build:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-07-14+05%3A00%3A00&maxdate=2005-07-15+08%3A00%3A00&cvsroot=%2Fcvsroot
Attached file testcase
This is quite annoying if you visit pages with frames or iframes.
Another nice testcase (assumes you have bfback enabled):
1. Go to http://tinderbox.mozilla.org/SeaMonkey/
2. Click any link to a different page, e.g. "Thunderbird" to see state of TB tree
3. Hit "Back"
4. See the 3 iframes for Ports, Firefox and Camino empty.

Note that scrollbars (e.g. on the iframe for the -Ports tinderboxen) are shown
in the correct state but can't be used.
Flags: blocking1.8b4?
*** Bug 301101 has been marked as a duplicate of this bug. ***
*** Bug 301151 has been marked as a duplicate of this bug. ***
This is making Google images annoyingly difficult to use with Firefox.
Keywords: top100
*** Bug 301198 has been marked as a duplicate of this bug. ***
I think this was fixed by the 292890 checkin.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
I confirmed to fix the problem.
Thanks!
Blocks: 301448
Flags: blocking1.8b4?
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.