firefox mac: download zip file with icons in it, extract, 0 k files, no icons, always.

RESOLVED INVALID

Status

()

Firefox
Shell Integration
--
critical
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: lucie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

It is not possible to download zipped iconfiles with firefox from
http://interfacelift.com, http://resexcellence.com or any other page that offers
zipped mac os x icons. The icons are not accessible after extracting the zipfile.
only zip files, not happening with sit or dmg files.

Reproducible: Always

Steps to Reproduce:
1.download
http://www.pixelgirlpresents.com/images/downloads/Starwarsiconsmac.zip (or any
other zipfile with icons in it) using firefox.
2.Extract the zipfile using stuffit


Actual Results:  
3. Folder "Starwarsiconsmac Folder" is on the Desktop

In this folder are two subfolders. In "Starwarsiconsmac Folder/Starwars icons-1"
is a textfile and a folder named icons. In that icon folder are 0k iconfiles.
In the "Starwarsiconsmac Folder/__MACOSX/" is a folder named Starwars icons-1"
(size 810.989 bytes) with nothing visible in it. Nothing is visible using the
Terminal (ls), too. So, no icons there.

Tested on 3 different pages with multiple zipfiles and it is always the same
result. It is only happening with zipfiles. NO SIT or DMG files are affected.



Expected Results:  
3. Folder "Starwars icons-1" is on the Desktop

In this folder is a text file and one subfolder named "Starwars icons-1". In
there is a folder named "icons" and in there are the icons (..., no yoda 8().
Terminal shows exactly the same directories and files.

so i expected what safari and the internet explorer did with this file.

OS: Mac OS X 10.3.9 (7W98)
Kernel: Darwin 7.9.0
File system: Mac OS Extendet (Journaled)
Stuffit: Version 7.0.3 (comes with os x 10.3)

Comment 1

13 years ago
WFM
10.4.2

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716
Firefox/1.0.6

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050716
Firefox/1.0+ (PowerBook)

Have you tried a new profile?
(Reporter)

Comment 2

13 years ago
Another OS X Profile?
It is doing it on 2 different laptops.
I will try another macintosh today.

Comment 3

13 years ago
Make a new Firefox profile... type the following into your terminal window

`/Applications/Firefox.app/Contents/MacOS/firefox-bin -p`

That should bring up the profile manager... create a new Firefox profile... just
walk thru the steps :)

I would suggest that you uncheck the "Don't Ask at Startup" this way you can
simply quit Firefox relaunch it and select your old profile... and the recheck it.

Like I said WFM with 10.4.2 with Firefox 1.0.6 and Deer Park Alpha 2+
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> Make a new Firefox profile... type the following into your terminal window
> 
> `/Applications/Firefox.app/Contents/MacOS/firefox-bin -p`
> 
> That should bring up the profile manager... create a new Firefox profile... just
> walk thru the steps :)
> 
> I would suggest that you uncheck the "Don't Ask at Startup" this way you can
> simply quit Firefox relaunch it and select your old profile... and the recheck it.
> 

what does a profile have to do with this problem? I set up a powermac g4 today
and the first thing i did after i made all updates to 10.3.9, was to download a
zipfile that was as useless as on the other 2 macs.
But... I did what you said. Results:

Terminal:

localhost:~ lucie$ /Applications/Firefox.app/Contents/MacOS/firefox-bin -p
/Applications/Firefox.app/Contents/MacOS/firefox-bin: can't map file:
/Library/Internet Plug-Ins/Java Applet.plugin ((os/kern) invalid argument)
localhost:~ lucie$ /Applications/Firefox.app/Contents/MacOS/firefox-bin: can't
map file: /Library/Internet Plug-Ins/Java Applet.plugin ((os/kern) invalid argument)
*** nsExtensionManager::_disableObsoleteExtensions - failure, catching exception
so finalize window can close
*** loading the extensions datasource
/Applications/Firefox.app/Contents/MacOS/firefox-bin: can't map file:
/Library/Internet Plug-Ins/Java Applet.plugin ((os/kern) invalid argument)
*** loading the extensions datasource

localhost:~ lucie$ 

Iconzips:

still useless, no icons. Everything as it was before.


> Like I said WFM with 10.4.2 with Firefox 1.0.6 and Deer Park Alpha 2+

a) what is WFM
b) I do not have 10.4 by now. all machines have 10.3.9
c) do not have deer park alpha, too. dont know what this is, too.

Comment 5

13 years ago
WFM == Works For Me

I new Firefox profile ensure Firefox is known state... the default shipping
state... this make it simpler to track down the problem... for instance lets say
you had three extensions installed and made a few modifications to the prefs...
well what causes the problem... the extensions... the pref changes... or does
the problem exist out of the box...

So with a new profile the bug still exist... possible problems with 10.3.x and 1.0.5

Do all downloads fail or just *.zips?
(Reporter)

Comment 6

13 years ago
Ahoi again,
i posted a bug, so I am pretty sure that it is a problem that comes out of the
box when using firefox (I never installed any extensions for firefox). on two
macs I downloaded the zipfiles just after installing the os, installing firefox
and updading the os (security updates, itunes updates, the usual stuff).
It is, as written above, only a zip problem. No sit or dmg problem.
And it is, as written above, a not possible to download iconfiles in zipfiles with:
OS: Mac OS X 10.3.9 (7W98)
Kernel: Darwin 7.9.0
File system: Mac OS Extendet (Journaled)
Stuffit: Version 7.0.3 (comes with os x 10.3)

I downloaded the SAME icon zipfile with safari and there the file is as it has
to be.

This is INVALID.  

The problem is you're opening the zip files with StuffIt 7.x, which doesn't
support Apple's 10.3-and-above zip archives (StuffIt 9.x is current).  Either
open the archives with Apple's BOMArchiveHelper (that's what Safari does) or
upgrade to a version of StuffIt Expander that supports Apple's zip archives.  

(WFM, BTW, on 10.3.9 with Fx 1.0.6 and DP 20050818 branch, with StuffIt Expander
8.0.2 and BOMArchiveHandler)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

13 years ago
(In reply to comment #7)
> This is INVALID.  
> 
> The problem is you're opening the zip files with StuffIt 7.x, which doesn't
> support Apple's 10.3-and-above zip archives (StuffIt 9.x is current).  Either
> open the archives with Apple's BOMArchiveHelper (that's what Safari does) or
> upgrade to a version of StuffIt Expander that supports Apple's zip archives.  
> 
> (WFM, BTW, on 10.3.9 with Fx 1.0.6 and DP 20050818 branch, with StuffIt Expander
> 8.0.2 and BOMArchiveHandler)

Tank You for this reply, everyting is fine again 8)
For people searching the BOMArchiveHelper:
The app is in /System/Library/CoreServices/
You need to log in before you can comment on or make changes to this bug.