Audio in Firefox causes things such as Flash video to "studder."

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: admin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

While watching ossmixer (from the commercial version of OSS), I can watch
Firefox allocate and deallocate a sound device every time a single sound is
played. This is why I think it is causing the studdering. This doesn't happen in
Windows. 

My first thought is that this is caused by a workaround done a long time ago
because Linux lacked support for virtual sound channels. For example, older
soundcards such as the SoundBlaster PCI 128 could only do one thing at a
time--i.e., xmms would be playing mp3s and no other application could use sound. 

Could this be the case? 

Reproducible: Always

Steps to Reproduce:
1. Open a Flash Game/Animation
2. Do something that causes a sound to play
3. Watch in horror as you miss the shot because firefox studdered. 

Actual Results:  
I was really mad because I missed the shot.

Expected Results:  
I should have made the shot!

Though I wasn't being very serious in the 2 fields above, this is an annoyance
and I think it should be fixed.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 265200 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
This bug is not a duplicate as the issue is completely different. 
Bug 265200 is referring to the inability to play audio while using flash with
audio--which is not my issue. 

My issue is that Firefox allocated and deallocates the sound device everytime a
single sound is played. I'm able to play other audio while listening to flash
audio with no problems. The problem comes when a flash animation plays a sound
and the browser locks up for a split second while allocating a sound
channel--e.g., "studders." 
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Firefox doesn't do sounds, the plugin itself does that.
That means that this must be fixed in the flash player itself.
And of course, yoi reported a bug about flash and you didn't include the used
flash version - that's always bad.


(Reporter)

Comment 4

13 years ago
The version wouldn't matter all that much as it has always done this since I can
remember. But, if you really need it: 7.0.25.0
(Reporter)

Comment 5

13 years ago
No one is going to take this seriously because the devteam no longer cares about
people, so I'm going to close it and ignore it. I didn't have to take my time to
help you guys out and report a bug, yet I'm the one getting looked down on.
Forget it, you guys are no better than Microsoft. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WONTFIX
(In reply to comment #5)

Please read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html very
carefully before making further comments.

Also, only module peers should close bugs as wontfix -> reopen
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 7

13 years ago
resolving INVALID -- this is not a Mozilla bug

Steven: no one is looking down on you.  We're just saying that it's Mozilla's
fault and there's nothing we can do about it.  If you want it fixed, the best
way is to report it to Macromedia.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.