-console doesn't work from cygwin bash

RESOLVED WONTFIX

Status

Core Graveyard
Cmd-line Features
--
major
RESOLVED WONTFIX
13 years ago
9 years ago

People

(Reporter: BenB, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Reproduction:
1. Open cygwin bash
2. There, start Mozilla using |mozilla.exe -console|
3. Open Windows commandline (cmd.exe)
4. There, start Mozilla using |mozilla.exe -console|

Expected result:
No difference between step 2 and 4.

Actual result:
Step 4 works (you see "stdout redirected..." and dump statements, if enabled in
prefs)
Step 2 doesn't work: It opens a new console window, but you never see any
contents in it.

Comment 1

12 years ago
Huh, this is extremely annoying. I just spend quite some time trying to reproduce some exception dumps to the console some Linux guy claimed were there...
This is for sure a major flaw for Cygwin based hackers.
Severity: normal → major
(Reporter)

Comment 2

12 years ago
Yeah, FYI, this probably costed me a full working day all in all until I realized what the cause was that I don't see dump()s. This is something I simply didn't think of as possible cause.

Comment 3

9 years ago
Not sure what's going on here, but I'm pretty sure it's a bug in the shell, not in Firefox, so I don't think there's anything else to do here.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

9 years ago
bsmedmerg, note that starting Mozilla from cygwin bash opens a new (cmd.exe-like) window with console (but dump() statements never end up there), but starting Mozilla from cmd.exe-console IIRC prints dump() statments directly in the original console. So, this may very well be a Mozilla bug.
(Reporter)

Updated

9 years ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 5

9 years ago
I still don't care... it's not worth fixing.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WONTFIX

Updated

9 years ago
Component: Cmd-line Features → Cmd-line Features
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.