back button does not provide access to "good" version of page with error

RESOLVED DUPLICATE of bug 74349

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 74349
13 years ago
10 years ago

People

(Reporter: Brennan Vincent, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME (INVALID)?)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

When reloading a page, if an error occurred on that page the back button is
disabled, not letting the user return to the cached "good" version of page

Reproducible: Always

Steps to Reproduce:
1. Go to a page on a web server you control
2. Kill the server
3. Reload the page

Actual Results:  
Back button is either grayed out or provides access to the page prior to the
reloaded page

Expected Results:  
Back button provides access to previously cached version of reloaded page.
(Reporter)

Comment 1

13 years ago
Sorry if I did anything wrong, this is my first time ever reporting a bug.

Comment 2

11 years ago
Confirmed with
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007082004 Minefield/3.0a8pre
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.7pre) Gecko/20070820 BonEcho/2.0.0.7pre

The Back button goes back in history. Reload means “reload”.
Not sure if anything can be done about that.
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk

Updated

11 years ago
Whiteboard: CLOSEME (INVALID)?
Well, at timeout, failed connection, page load error etc alerts, you could add an option to load page from disk cache, if present.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 74349

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.