Status

()

Core
HTML: Parser
P2
normal
VERIFIED DUPLICATE of bug 1839
19 years ago
19 years ago

People

(Reporter: Michael Lowe, Assigned: vidur (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Cited URL is not displaying properly.  Suspected parser bug.

Updated

19 years ago
Assignee: rickg → karnaze

Comment 1

19 years ago
This actually looks like a frameset bug. Can you look into it?

Updated

19 years ago
Assignee: karnaze → rickg

Comment 2

19 years ago
This should be a frameset document (because it has a <frameset> before a
<body>), but the content model includes the body and all of its children. The
parser needs to ignore <body> tags when a <frameset> preceeds a <body>. It
should also ignore <frameset> when a <body> preceeds a <frameset>.

Updated

19 years ago
Assignee: rickg → vidur

Comment 3

19 years ago
This is not actually a parser bug -- no weirdness is occuring in the document
from the parser's perspective.

Upon further analysis, it appears that the js at the top of the frame-page
causes much weirdness in the frame. What you'll see is that the bottom-frame
document appears empty.

Vidur, please take a look at the js, and try to deduce what might be actually
happening inside our frame document. Thanks.

Comment 4

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

19 years ago
This is happening because the page tries to reference a frame as a named
property of the top window and fails.

*** This bug has been marked as a duplicate of 1839 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.