Lock does not appear when mail account using SSL connections is created

VERIFIED DUPLICATE of bug 31685

Status

VERIFIED DUPLICATE of bug 31685
13 years ago
13 years ago

People

(Reporter: edwardp, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050715 SeaMonkey/1.0a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050715 SeaMonkey/1.0a

The lock does not appear to the left of the account name for an e-mail account
that uses SSL connections on both POP and SMTP servers.  

This is with a brand new profile that was created.  The old Mozilla profile
though, caused SeaMonkey to correctly displayed the lock  icon.

The lock does correctly appear for a newsgroup account that also uses an SSL
connection.


Reproducible: Always

Steps to Reproduce:
1.Mail account is created, buttons for SSL connections (POP and SMTP) are checked.
2.SeaMonkey is exited completely.
3.SeaMonkey is reopened, Mail & Newsgroups icon is clicked, the lock icon for
the SSL account is not displayed.  This is with a newly-created profile.

Actual Results:  
Account name for SSL mail account appears with the standard letter icon.

Expected Results:  
Since both the POP and SMTP settings for the account in question use SSL
connections, the letter with the lock icon should have appeared.

Both the July 16 and 17, 2005 Windows builds crashing after installation,
corrupted the old Mozilla 1.7.x profile which SeaMonkey had used, this required
the creation of a new profile.

Could it be that some type of preference setting that had been set in Mozilla,
is not set in SeaMonkey?
(Reporter)

Comment 1

13 years ago
This required the addition of:

mail.server.serverX.isSecure to be 

added to about:config as boolean with the value:  true

When the above was added in via about:config, the lock correctly appeared upon
the next launch of SeaMonkey.

(Reporter)

Comment 2

13 years ago
The "X" in the line added to about:config, is the mail server number associated
with the mail account.

Comment 3

13 years ago
confirmed with linux suite trunk 20050716
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Version: unspecified → Trunk

Comment 4

13 years ago
Ah, I think I know what this might be.
Originally we only had a simple unsecure/secure server setting.
Now we have the choice of Never, If Available, TLS and SSL.
But the folder pane UI only looks at the old setting.
Flags: blocking-seamonkey1.0a?

Comment 5

13 years ago
Sounds v. similar to bug 31685.

*** This bug has been marked as a duplicate of 304466 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Flags: blocking-seamonkey1.0a?
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

13 years ago
Reopening this bug.  The problem is also present when there is a newsgroup
account set up for SSL connections, the lock does not appear for that entry.

I checked the about:config file, the line for the news server

mail.server.server##.isSecure            boolean         true

is there, but no lock appears next to the account name.

This is with the Linux version of SeaMonkey.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

13 years ago
I had to manually set socketType to 3 for the server in my prefs.js to get the
icon to show up.
(Reporter)

Comment 9

13 years ago
I searched for "socket" in about:config, two lines appeared, the line for the
server defaulted to 0 (zero).  Changing this to 3, took care of the problem.

Should this bug be left open so it can be fixed before SM comes out of alpha/beta?

Comment 10

13 years ago
OK, then perhaps this is the duplicate of a different bug :-)

*** This bug has been marked as a duplicate of 31685 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.