Deer Park Alpha 2 Talkback not working

RESOLVED DUPLICATE of bug 297312

Status

Core Graveyard
Talkback Client
--
major
RESOLVED DUPLICATE of bug 297312
13 years ago
9 years ago

People

(Reporter: Hermann Schwab, Assigned: jay)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

tested with some known crasher bugs, DrWatson came up, Talkbug was silent.
I checked install_status.log and install_wizard.log, ok.
Talkbackfiles files are in the extensions/talkback@mozilla.org/components
directory, ok.
No success trying workaround from 
Bug 253750 Talkback doesn't launch anymore on crash for non-installer builds due
to compreg.dat file (which doesn't have Talkback registered)

could it be that em:version in install.rdf is wrong?

  <Description about="urn:mozilla:install-manifest">
    <em:id>talkback@mozilla.org</em:id>
    <em:version>1.7+</em:version>
(Reporter)

Comment 1

13 years ago
There was even more missing, as seen in JS console.

Install Location returned an item path that does not exist! Item Path:
C:\PROGRAMME\MOZILLA.ORG\ZIPS\FIREFOX\extensions\{972ce4c6-7e08-4474-a285-3208198ce6fd},
Location Key: app-global Item ID: {972ce4c6-7e08-4474-a285-3208198ce6fd}
Install Location returned an item path that does not exist! Item Path:
C:\PROGRAMME\MOZILLA.ORG\ZIPS\FIREFOX\extensions\inspector@mozilla.org, Location
Key: app-global Item ID: inspector@mozilla.org
Install Location returned an item path that does not exist! Item Path:
C:\PROGRAMME\MOZILLA.ORG\ZIPS\FIREFOX\extensions\reporter@mozilla.org, Location
Key: app-global Item ID: reporter@mozilla.org
Install Location returned an item path that does not exist! Item Path:
C:\PROGRAMME\MOZILLA.ORG\ZIPS\FIREFOX\extensions\talkback@mozilla.org, Location
Key: app-global Item ID: talkback@mozilla.org
Error: syntax error
Source File:
https://aus.mozilla.org/update2/0/Firefox/1.0%2B/2005071006/WINNT_x86-msvc/en-US/update.xml
Line: 1, Column: 50
Source Code:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">

Reason: I'm using zips in one location, and one exe-installed Firefox in another
location, different profiles for Deer Park and Firefox.

So I had unpacked 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b3) Gecko/20050710 Firefox/1.0+
in C:\PROGRAMME\MOZILLA.ORG\ZIPS\FIREFOX
and had that renamed to
C:\PROGRAMME\MOZILLA.ORG\ZIPS\FIREFOX_
to unpack 1.0.6 into a new folder, and renamed that from
C:\PROGRAMME\MOZILLA.ORG\ZIPS\FIREFOX
to 
C:\PROGRAMME\MOZILLA.ORG\ZIPS\F1.0.6

so 
C:\PROGRAMME\MOZILLA.ORG\ZIPS\FIREFOX didn´t exist.

I installed Deerpark alpha 2 in a custom installation to:
C:\PROGRAMME\MOZILLA.ORG\DeerPark

After I found the messages above, I deinstalled and reinstalled, with same
result. Started the unzipped deerpark, same result.
Renamed the folder holding the unzipped to Firefox, and the unzipped version was
working.
Closed unzipped version, started installed version, also working, though I
highly suspect it isn´t using the extensions in its own folder, but that from
the zip.
I`m using the same profile for the two deerpark versions, and there is only one
extension installed in the profile, LiveHTTPHeaders.
(Reporter)

Comment 2

13 years ago
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=7575648
started 1.8b3: 2005071206 to crash it, talkback came up and i commented and sent.
couldn't find the talkbackId, so I searched for the comment and found the record
above in fastfind.
Talkback tells BuildID 	2005071006, so talkback was from the zip version 1.8b3:
2005071006

This bug isn´t about talkback, it is about something going wrong when having
multiple profiles, an exe and a zip version in deifferent directories.
Feel free to move or resolve invalid, don`t know yet.
(Reporter)

Comment 3

13 years ago
Bug 297312 EM gets confused between multiple installations of the same version

*** This bug has been marked as a duplicate of 297312 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: Talkback Client → Talkback Client
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.