Import Eudora mail fails to find attachments in other directories

RESOLVED FIXED in Thunderbird 3

Status

Thunderbird
Migration
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: pjw, Assigned: Geoffrey C. Wenger)

Tracking

Trunk
Thunderbird 3
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-penelope)

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I have moved my Eudora attachments folder several times. Old messages reflect
the old locations, but Eudora always looks in the current attachments folder.
When importing into Thunderbird, the code in nsEudoraMailbox.cpp seems to rely
in the full file path being correct. What would be great is if it could
interrogate Eudora (or the user) to add/find attachments folders when/if
necessary. All my attachments reside in the one folder.


Reproducible: Always

Steps to Reproduce:
1.Set Eudora attachments folder to C:\junk1
2.Receive attachment in Eudora
3.Set Eudora attachments folder to C:\junk2
4.Move files from C:\Junk1 to C:\Junk2, and verify Eudora finds them
4.Receive another attachment in Eudora
5.Import into Thunderbird



Actual Results:  
Attachments originally in junk1 will not be found by Thunderbird.

Expected Results:  
Interrogated Eudora or the user or Eudora settings to look for missing
attachment files in the default attachments folder. Possibly alert the user or
allow file browsing (but this would be a pin in large mailboxes)
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0

Comment 1

12 years ago
wontfix?

Comment 2

11 years ago
Confirmed, assigned to Penelope as the Penelope team is working on Eudora importers.
Assignee: mscott → gwenger
Status: UNCONFIRMED → NEW
Component: Migration → General
Ever confirmed: true
OS: Windows 2000 → All
Product: Thunderbird → Penelope
Target Milestone: --- → 0.5
Version: 1.0 → 0.1

Updated

11 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

11 years ago
Created attachment 260379 [details] [diff] [review]
Patch that fixes bug. Note patch was not created with CVS.

Now when an attachment can't be found at the original full path, the importer checks inside the "attach" directory in the Eudora mail directory. Looking in the actual attachment directory as specified by the settings will have to wait until we have better settings importing.
(Assignee)

Updated

11 years ago
Component: General → Migration
Product: Penelope → Thunderbird
Target Milestone: 0.5 → ---
Version: 0.1 → unspecified
(Assignee)

Updated

11 years ago
Attachment #260379 - Flags: superreview?(bienvenu)
Attachment #260379 - Flags: review?(bienvenu)

Comment 4

11 years ago
Geoffrey, thx for the path. Is it intended for the 2.0 branch, the trunk, or both?

The trunk is going through some big changes as I get rid of nsIFileSpec uses...
(Assignee)

Updated

11 years ago
Whiteboard: fixed-penelope
QA Contact: migration

Comment 5

11 years ago
Created attachment 263771 [details] [diff] [review]
remove filespec from prev patch

this is what I'm going to land on the trunk - I just replaced the file spec stuff with nsIFile.

Updated

11 years ago
Attachment #260379 - Flags: superreview?(bienvenu)
Attachment #260379 - Flags: superreview+
Attachment #260379 - Flags: review?(bienvenu)
Attachment #260379 - Flags: review+

Comment 6

11 years ago
I've landed the patch on the trunk, but I'm leaving the bug open because it sounds like we're waiting on the ability to import settings better...

Comment 7

10 years ago
I installd the New version of Eudora Penelope V 8.0.0b1 and tried to import my mail messages from my old Eudora V 7.1.0.9 and all importing was succeded except the out folder where all mails imported without attachments at all and i couldn't find solution for this problem to migrate and start using the new version i have installed. For me, i'm an old user of Eudora since years and i can't use any other program. Pls help.

amer.naghi@jubailibros.com

Comment 8

10 years ago
I'm using Eudora 8.0. I can't find attachments to incoming email. I can open them from the inbox window but they are downloading into the designated folder (configured in Tools/Options/Attachments/Attahcments Folder. Is this a server problem or a problem with Eudora 8? It seems as though the attachments are staying on my server and not downloading into the designated folder. Thanks for your advice.
(Assignee)

Comment 9

10 years ago
Created attachment 305085 [details] [diff] [review]
Trunk patch that fixes small bugs in the filespec modifications made to my original patch, which caused code not to work as originally intended.
(Assignee)

Updated

10 years ago
Attachment #305085 - Flags: superreview?(mscott)
Attachment #305085 - Flags: review?(bienvenu)

Updated

10 years ago
Attachment #305085 - Flags: review?(bienvenu) → review+

Updated

10 years ago
Attachment #305085 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed
Checking in mailnews/import/eudora/src/nsEudoraWin32.cpp;
/cvsroot/mozilla/mailnews/import/eudora/src/nsEudoraWin32.cpp,v  <--  nsEudoraWin32.cpp
new revision: 1.61; previous revision: 1.60
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3
Version: unspecified → Trunk

Comment 11

9 years ago
I am using Eidora on a Mac platform; this bug was not fixed in the latest realaes:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090108 Eudora/3.0b1pre

I have the following sentence showing on every imported file with an attachment:

** This attachment was missing when this message was exported. **

which is not correct.

Comment 12

9 years ago
did you re-import?

Comment 13

9 years ago
Several times (initially the app will crush on my old "out" file that had some corruption in it).
I than deleted the out file, imported all others. Mail displays well, but attachments are not linked.
I also reported that attachments are not saved in the specified path (not sure how to direct you to it, I am new to this and NOT fluent in any programing language).

Comment 14

9 years ago
Geoff, is this working for you on the trunk? I hope I didn't mess up the patch again...

Comment 15

9 years ago
while at it, can you please also look at Bug 477489 - (attached files saved on desktop, not at specified folder) ?
thx!!

Comment 16

9 years ago
The original fix for the original bug was made to Windows code, not Mac code.

That said, I get attachments imported from Classic Mac Eudora to Mac Eudora 8.

Rafi, are you sure the attachments do still exist on your machine?  Can you click on them in Classic Eudora messages and they open up fine?

Comment 17

9 years ago
Hi Jeff,
I get the attachment icon imported but the link is broken.
the folder and the attachments exist; that is not the issue. I tested and printed some with classic Eudora, and all is still in place.

again, clicking on te attachment icon in Eudora deposits a file on the desktop (even if the file only contains the line
** This attachment was missing when this message was exported. **
You need to log in before you can comment on or make changes to this bug.