Closed Bug 301191 Opened 18 years ago Closed 5 years ago

Warn before downgrading to an older version of an extension

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: benjamin, Unassigned)

References

Details

When you install an extension and a newer version is already present (and
enabled?), we should warn the user and ask whether they want to downgrade the
older version. This is especially important with multi-item XPIs, which may end
up accidentally downgrading JSLib or other utility extensions in bad ways.
Little related bug is Bug 296173.

After Bug 298497 fixed this bug could be less serious because older ver of e.g.
jslib could disable extensions depending on the newer ver of it (per em:requires
min/max).
Product: Firefox → Toolkit
Assignee: robert.bugzilla → nobody
Blocks: 502653
After talking to jorgev, it was deemed that reverting to a previous version of a webextension is rarely worthy of a warning.

CLosing this as a wontfix.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.