Duplicate search engines appearing in Toolbar Search menu

RESOLVED DUPLICATE of bug 299825

Status

()

RESOLVED DUPLICATE of bug 299825
13 years ago
13 years ago

People

(Reporter: aaronkelley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

This has been happening for me on multiple computers with Deer Park Alpha 2
(Windows).  It seems that search plugins are being copied from the
"[installation folder]\searchplugins" folder to the "[profile
folder]\searchplugins" folder -- which causes them to show up twice in the list
of search engines (after Deer Park is restarted).

Removing search engines from the profile folder removes the duplicates from the
list.

Reproducible: Sometimes

Steps to Reproduce:
Happens after running searches with different engines (but not always).  I
haven't found a 100% reliable way to reproduce it, but it happens frequently
enough to be very noticable.
Actual Results:  
After using multiple engines for a while and restarting Firefox, some search
engines appear twice in the list (often, the duplicates do not have an icon).

Expected Results:  
Search engines should not be duplicated (as with Firefox 1.0.x, Deer Park Alpha 1).
(Reporter)

Comment 1

13 years ago
Created attachment 189670 [details]
Screen shot - Google duplicated
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Relation with Bug 300738 ?

That bug is about search plugins coming back when an update to Firefox is
applied (because the default search plugins are reinstalled with Firefox). 
That's not really the problem here -- I'm seeing plugins copied from the
"global" searchplugins folder to the profile one (seems to happen when I'm
switching and running searches with different engines, but is not 100%
reproducable).
Sounds like a dupe of bug 299825
(Reporter)

Comment 5

13 years ago
Yeah, looks like it.  I guess it was just happening on an update -- and since I
was deleting the "new" plugins from the profile folder, it kept happening again.

*** This bug has been marked as a duplicate of 299825 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.