Thunderbird hangs when accessing large mail folder (>500Mb, >12000 messages)

RESOLVED DUPLICATE of bug 286888

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 286888
13 years ago
13 years ago

People

(Reporter: Chris January, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

I have a Junk mail folder that has not been emptied for some time. The folder is
approximately 500Mb on disk. When I click on the Junk folder in Thunderbird the
application hangs and is still hung after 20 minutes.

Reproducible: Always

Steps to Reproduce:
1.Fill the Junk mail folder with a lot mail (e.g. 12000 messages).
2.Try to open the Junk folder by clicking on it in the Folders pane


Actual Results:  
The application hung.

Expected Results:  
The messages pane should show a list of messages in the Junk mail folder.
(Reporter)

Comment 1

13 years ago
I tried compacting the folder and now it can be accessed.

Comment 2

13 years ago
Resolving as WORKSFORME per reporter's comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 3

13 years ago
why would you resolve this as worksforme? Compacting the folder is a workaround
for the problem, but it sounds like the problem is still there for those who
wouldn't think to do this...... Reopen? 
(Reporter)

Comment 4

13 years ago
I agree with the above poster.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

13 years ago
(In reply to comment #3)
> but it sounds like the problem is still there for those who
> wouldn't think to do this...

OK. We'll have it do it automatically then.


*** This bug has been marked as a duplicate of 286888 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.