Unable to select and copy/paste address data in card summary pane

RESOLVED DUPLICATE of bug 96968

Status

enhancement
RESOLVED DUPLICATE of bug 96968
14 years ago
14 years ago

People

(Reporter: chris_siller, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

In the card summary pane of the address book, I can't select/highlight data with
the mouse and copy it. This is extremely cumbersome: whenever I want to send
someone all my contact info or write a snail-mail letter, I have to go to the
edit mask of the contact in question and copy/paste the info line by line.
This extremely annoying and renders the address book completely useless for
purposes other than simply collecting email addresses.

It only makes sense to keep eg. postal addresses in the Thunderbird addressbook
if it is possible to access that information. Since postal addresses are
typically used in progams other than Thunderbird (eg. word processor),
copy/paste functionality is crucial.

Reproducible: Always

Steps to Reproduce:
1. select a card in the address book
2. try to select any address data in the card summary pane
3.

Actual Results:  
no text in the card summary pane can be selected and copied to the clipboard.

Expected Results:  
it should be possible to select the text (e.g. the postal address paragraph) and
copy it with control-c or the context menu to the clipboard.

*** This bug has been marked as a duplicate of 96968 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.