Firefox crashes or freezes with java

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: vaclavpe, Unassigned)

Tracking

({crash, hang})

1.0 Branch
x86
Linux
crash, hang
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

On the abovementioned page Java machine asks for proxy name/passwd. But it is
not possible to write anything into test boxes. After clicking "Cancel" FF
freezes. Sometimes no passwd window appears and FF crashes.
On console I got following:
vaclavp@pcdyn4144:~> /opt/firefox-1.0/firefox

(firefox-bin:25266): Gdk-WARNING **: gdk_property_get(): length value has
wrapped in calculation (did you pass G_MAXLONG?)
Java property javaplugin.jre.path defined as
/tmp/jre1.5.0_02
But that directory does not exist.
Using JRE from
/opt/jre1.5.0_02
rem:Set array arr=81ACF48 start=0 len=25 buf[0]=118
/opt/firefox-1.0/run-mozilla.sh: line 451: 25266 Killed                  "$prog"
${1+"$@"}



Reproducible: Always

Steps to Reproduce:
1. Install Java
2. Run Firefox
3. Go to this page: http://perso.numericable.fr/~gjullien/satellite.htm

Actual Results:  
Freeze/crash

Expected Results:  
Correctly run java applets

vaclavp@pcdyn4144:~> /opt/firefox-1.0/firefox

(firefox-bin:25266): Gdk-WARNING **: gdk_property_get(): length value has
wrapped in calculation (did you pass G_MAXLONG?)
Java property javaplugin.jre.path defined as
/tmp/jre1.5.0_02
But that directory does not exist.
Using JRE from
/opt/jre1.5.0_02
rem:Set array arr=81ACF48 start=0 len=25 buf[0]=118
/opt/firefox-1.0/run-mozilla.sh: line 451: 25266 Killed                  "$prog"
${1+"$@"}

Updated

13 years ago
Keywords: crash, hang

Comment 1

13 years ago
WFM, nothing freezes for me and the applets run correcly though firefox slows
down while the applets are loading but this is appearent with all other browsers
too including MSIE on windows.

Comment 2

13 years ago
I'm experiencing the same issue. Firefox 1.5 freezes when trying to load a homepage that contains a Java applet. For example, go to www.EPLtalk.com and you'll see that it freezes. The site worked fine with Firefox 1.0.

Updated

12 years ago
Blocks: 353557

Comment 3

12 years ago
The link works fine on my box:
Java(TM) Plug-in 1.5.0_08-b03
Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.8.0.4) Gecko/20060731 Firefox/1.5.0.4

Updated

12 years ago
No longer blocks: 353557
works for me with the latest java release

Reporter, do you still see this problem on a recent Firefox Release ?

If so, could you provide a Talkback ID from the crash ?
(http://kb.mozillazine.org/Talkback)
Version: unspecified → 1.0 Branch
closing wfm per comment 4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.