bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Can not drag and drop a file from a Linux desktop onto an html page

RESOLVED INCOMPLETE

Status

()

Firefox
Shell Integration
RESOLVED INCOMPLETE
13 years ago
8 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-09-17], URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050718 Firefox/1.0+

I was looking around for a way to allow the vistors of a webpage to drap and
drop files on it (to help in uploading files).  I found this site
http://straxus.javadevelopersjournal.com/creating_a_mozillafirefox_drag_and_drop_file_upload_script_p.htm
which described how to accomplish this in Firefox/Mozilla.  As it says, this
script should only run as a file or as a signed script.

When I run it as a file (I haven't signed it so you will need to run it as a
file), it will successfully get the file I drag to it when I am using Firefox on
Windows.  But when I do it on Linux (either Gnome or KDE), I get an exception
that says:
Component returned yailure code: 0x80004005 (NS_ERROR_FAILURE)
[nsITransferable.getTransferData) ...

My guess is that this component is implemented in Windows, but hasn't been
implemented in Linux.  Could it be that because of the different window managers
(KDE, GNOME, EvilWM, Fluxbox) it is impossible?

Reproducible: Always

Steps to Reproduce:
1.  Dowload the site onto your computer so that it is a local file
2.  Access the site using file:// (give it the permissions it needs)
3.  Drag a file from the desktop to the page

Actual Results:  
The actual results are that it does nothing.  You can see the debugging messages
on the screen and open up the Javascript console to see the exception

Expected Results:  
It should fill out the text box with the name of the file dragged to it.

I have tried this on Windows XP (works), KDE-3.2.2-6 Red Hat (not works), Gnome
2.6 (not works).

Comment 1

13 years ago
Created attachment 204711 [details]
testcase

Comment 2

11 years ago
The described behavior happens here on Debian Lenny with GNOME 2.18 and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007090304 Minefield/3.0a8pre and the testcase from comment #1.
Whiteboard: DUPEME?
Version: unspecified → Trunk

Comment 3

11 years ago
Looks pretty similar to bug 50660.

Comment 4

11 years ago
Seeing the same error doing drag and drop file imports on Linux on multiple versions of Firefox.

Comment 5

9 years ago
This is happening to me as well.  Minefield supports drag drop file just fine in Linux (Ubuntu)... seems as thought Beta 5 broke it.  The mozhacks demo doesn't work when dragging from desktop.
Do you still see this problem using the most recent versions of all components? If you do not, please close the bug with resolution set to WORKSFORME. If you do, please comment in the bug.
Whiteboard: DUPEME? → [closeme 2010-09-17]
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.