Closed Bug 301327 Opened 19 years ago Closed 19 years ago

zip package creation doesn't work, starting with 2005-07-19-07

Categories

(Firefox Build System :: General, defect, P1)

x86
Windows 98
defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.8beta4

People

(Reporter: hhschwab, Assigned: Biesinger)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Starting today I'm missing the zip files. I don´t archive the installers, as I
don´t want to install when I want to search when something regressed.

Log files are full of errors, and near the end building the zip package is aborted:

xpt_dump.exe
xpt_link.exe
Copying NSPR libs...
cp: cannot stat `/*.dll': No such file or directory
make[1]: *** [seamonkey-1.0a.en-US.win32.zip] Error 1
make[1]: Leaving directory
`/cygdrive/c/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpinstall/packager'
make: *** [all] Error 2
make: Leaving directory
`/cygdrive/c/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpinstall/packager'
cp
c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dist/install/../*.zip
c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dist/install/CREATURE/
cp: cannot stat
`c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dist/install/../*.zip':
No such file or directory
ssh  -l cltbld stage.mozilla.org mkdir -p /home/ftp/pub/seamonkey/tinderbox-builds
scp  -r
/cygdrive/c/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dist/install/CREATURE
cltbld@stage.mozilla.org:/home/ftp/pub/seamonkey/tinderbox-builds
ssh  -l cltbld stage.mozilla.org chmod -R 775
/home/ftp/pub/seamonkey/tinderbox-builds/CREATURE

No More Errors


yesterdays nightly that part of the log was looking like this:
xpt_dump.exe
xpt_link.exe
Stripping package directory...
signing nss libraries
../../dist/bin/run-mozilla.sh: not found
Removing unpackaged files...
cd ../../dist/seamonkey; rm -rf  core bsdecho gtscc jscpucfg nsinstall viewer
TestGtkEmbed bloaturls.txt codesighs* elf-dynstr-gc mangle* maptsv* mfc*
mkdepend* msdump* msmap* nm2tsv* nsinstall* rebasedlls* res/samples res/throbber
shlibsign* winEmbed.exe chrome/chrome.rdf chrome/app-chrome.manifest 
Compressing...
cd ../../dist; zip -r9D seamonkey-1.0a.en-US.win32.zip seamonkey
  adding: seamonkey/AccessibleMarshal.dll (deflated 64%)
...
...
lots of files added ...
...
...
  adding: seamonkey/xpt_link.exe (deflated 46%)
make[1]: Leaving directory
`/cygdrive/c/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpinstall/packager'
make: Leaving directory
`/cygdrive/c/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpinstall/packager'
cp
c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dist/install/../*.zip
c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dist/install/2005-07-18-06-trunk/
ssh  -l cltbld stage.mozilla.org mkdir -p /home/ftp/pub/seamonkey/nightly
scp  -r
/cygdrive/c/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dist/install/2005-07-18-06-trunk
cltbld@stage.mozilla.org:/home/ftp/pub/seamonkey/nightly
ssh  -l cltbld stage.mozilla.org chmod -R 775
/home/ftp/pub/seamonkey/nightly/2005-07-18-06-trunk
ssh  -l cltbld stage.mozilla.org cp -pf
/home/ftp/pub/seamonkey/nightly/2005-07-18-06-trunk/*
/home/ftp/pub/seamonkey/nightly/latest-trunk/
cp: omitting directory
`/home/ftp/pub/seamonkey/nightly/2005-07-18-06-trunk/windows-xpi'

WINNT Mozilla Build available at: 
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/2005-07-18-06-trunk/ 
 

No More Errors
ok:     WINNT 5.0 creature Clobber on 07/18 11:50:00
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1121712600.5383.gz 

broken: WINNT 5.0 creature Clobber on 07/18 13:29:00
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1121718540.21031.gz

maybe caused by 
Bug 301219 	Remove rm hack from glue Makefile

Keywords: regression
>Copying NSPR libs...
>cp: cannot stat `/*.dll': No such file or directory

maybe Bug 301158? I really have a hard time imagining that bug 301219 caused this.
Flags: blocking-seamonkey1.0a+
creature just uploaded another set of builds, still it misses the .zip with the
same error :(
Summary: 2005-07-19-07-trunk/ zip builds missing from CREATURE → zip builds missing from CREATURE, starting with 2005-07-19-07
bleh, no -L in windows commandlines, so this line:
http://lxr.mozilla.org/seamonkey/source/toolkit/mozapps/installer/packager.mk#130
130 NSPR_LDIR       = $(findstring -L,$(NSPR_LIBS))

makes that variable empty; consequently, 
216         @cp -p $(NSPR_LDIR)/*$(DLL_SUFFIX) $(DIST)/$(MOZ_PKG_APPNAME)
won't copy anything.
firefox is not affected because it uses a manifest, which skips this codepath.
Attached patch patchSplinter Review
so all in all, I don't think we need to copy NSPR at all.

- if we used --with-system-nspr, then we use the system one, and can expect it
to be there
- if we didn't, then we already have NSPR in dist/bin, because otherwise,
builds wouldn't start from there. so the line above already took care of it.
Assignee: nobody → cbiesinger
Status: NEW → ASSIGNED
Attachment #189929 - Flags: review?(caillon)
Attachment #189929 - Flags: review?(benjamin)
Attachment #189929 - Flags: review?(benjamin)
Attachment #189929 - Flags: review+
Attachment #189929 - Flags: approval1.8b4+
Attachment #189929 - Flags: review?(caillon) → review+
Checking in toolkit/mozapps/installer/packager.mk;
/cvsroot/mozilla/toolkit/mozapps/installer/packager.mk,v  <--  packager.mk
new revision: 1.15; previous revision: 1.14
done
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Target Milestone: --- → Seamonkey1.0alpha
Looks like this is affecting Sunbird packaging on Windows, too.  It's a good
argument for retailoring summary and retargeting against Core/Build Config.
Respin of Sunbird post fix landing led to a compressed archive being created and
uploaded to stage.  I'll mark as verified with assumption that a SeaMonkey
tester will add a note about the result of tomorrow's build, too.
Status: RESOLVED → VERIFIED
Flags: blocking-seamonkey1.0a+
Priority: -- → P1
Product: Mozilla Application Suite → Core
Summary: zip builds missing from CREATURE, starting with 2005-07-19-07 → zip package creation doesn't work, starting with 2005-07-19-07
Target Milestone: Seamonkey1.0alpha → mozilla1.8beta4
just for the record, zip packages are there again, but don't like some
extensions, see

Bug 301532 Bottom edge of browser frame is very wide and has red text written on
it, see Summary
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: