Mac OS X Updater shows the wrong String

VERIFIED FIXED in mozilla1.8final

Status

()

Toolkit
Application Update
--
critical
VERIFIED FIXED
13 years ago
10 years ago

People

(Reporter: Scott MacGregor, Assigned: Darin Fisher)

Tracking

({verified1.8})

unspecified
mozilla1.8final
PowerPC
Mac OS X
verified1.8
Points:
---
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

788 bytes, patch
Scott MacGregor
: review+
Benjamin Smedberg
: approval1.8b4+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
When I do a Thunderbird update on Mac OS X. The updater dialog that comes up
refers to Firefox and not Thunderbird. 

"Applying updates to Firefox.  Please do not interrupt this process."

Even though we have the right updater.ini file in the application package. That
file shows the right string, but the string we actually show in the UI says
Firefox. I'm not sure why that is.
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.1?
Maybe move the NIB file(s?) into the app level?
(Assignee)

Comment 2

13 years ago
This is pretty odd.  I guess the Cocoa calls aren't working properly.  Pointer
to the code:
http://lxr.mozilla.org/mozilla/source/toolkit/mozapps/update/src/updater/progressui_osx.mm#72

Josh: can you help with this bug?

Comment 3

13 years ago
I'll take a look tonight.

Comment 4

13 years ago
The problem isn't the cocoa calls - they work fine, as you can see with Firefox.

The problem seems to be that in Deer Park, you copy
"DeerPark.app/Contents/MacOS/updater.ini" into the updater.app bundle that goes
in "DeerPark.app/Contents/MacOS/updates/0/". You're not doing that in
Thunderbird, so updater.ini isn't being found, and the default nib strings are
showing up. The defaults have "Firefox" in them.

I'll leave it up to you to sort out how you want to fix this since it'll
probably be easy now that you know that. I recommend that you change the default
strings in the nib (in the content area and the title) to something like
"default string" so that it is obvious when you can't find updater.ini, instead
of fooling you into thinking it is setting strings with "Firefox" in them.
(Assignee)

Comment 5

13 years ago
Created attachment 190080 [details] [diff] [review]
v1 patch

I haven't tested this patch, but I believe it should do the trick.  This is
just copy paste from browser/locale/Makefile.in.  My fault for not applying
this change to mail/locale/Makefile.in back when I made the change for firefox.


Can someone please help verify this fix?
Attachment #190080 - Flags: review?(mscott)
(Assignee)

Updated

13 years ago
Severity: normal → critical
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox1.1
(Assignee)

Comment 6

13 years ago
Josh: I don't have time to update the nib file.  If you could help with that,
it'd be greatly appreciated.  Otherwise, I think my patch here is sufficient
(provided it works).
(Reporter)

Comment 7

13 years ago
Comment on attachment 190080 [details] [diff] [review]
v1 patch

looks pretty straightforward to me.
Attachment #190080 - Flags: review?(mscott) → review+
(Assignee)

Updated

13 years ago
Attachment #190080 - Flags: approval1.8b4?

Comment 8

13 years ago
I checked in more obvious default strings for the nib earlier today, a=asa

Updated

13 years ago
Attachment #190080 - Flags: approval1.8b4? → approval1.8b4+

Updated

13 years ago
Flags: blocking-aviary1.5? → blocking1.8b4+
(Assignee)

Comment 9

13 years ago
fixed-on-trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Keywords: fixed1.8

Updated

13 years ago
Status: RESOLVED → VERIFIED
Keywords: fixed1.8 → verified1.8
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.