Chipdrive SmartCard Office - Password Manager loops while writing to smartcard

RESOLVED INVALID

Status

()

Firefox
Shell Integration
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Marcel Dunkelberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

I am using a smartcard reader with a software suite called Chipdrive SmartCard
Office. One package of it is called "Password Manager" which does nearly the
same as the integrated "Password Manager" in FF - but it saves the passwords on
a chipcard. After installing FF 1.0.3 or 1.0.4 the problem occured that when i
finished entering the credentials for a page (eg. Username/Password for
Bugzilla) the "Writing to chipcard" popup came up und after writing it again and
again writes the credentials to that card until the whole application "SCO
Password Manager" crashes.

I called their support and the know the problem - it is something wrong with the
interaction between FF and the Smartcard Office Suite which cannot be solved by
them because it is a FF issue.

Reproducible: Always

Steps to Reproduce:
1. Open a webpage which has Username/Password forms
2. After clicking "Submit" the Password Manager writes the combination to card
3. Again and again until crash

Actual Results:  
Smartcard Office Suite - Password Manager Services crashes

Expected Results:  
After Step 2 the password manager should go in idle until a new
Username/Password form is visited

Used Hardware:

* reiner-sct pinpad HBCI Chipcard Reader (http://tinyurl.com/bp9ql)
* Chipdrive Smartcard Office (http://tinyurl.com/7xqgf)

Used Chipcards:

* Chipdrive Masterkey 8kB Smartcard
(Reporter)

Comment 1

13 years ago
after talking to #firefox and testing with DPa2 the problem still exists...
(Reporter)

Comment 2

13 years ago
Created attachment 189966 [details]
Shows the installed application modules and their version

This Screenshots shows the builds for the crashing app.
If they're saying the problem is in Firefox, I would hope they have actual proof
and an explanation of what is actually wrong, as opposed to just blaming the
other guy.  If they have real information, that needs to be added to the bug or
this will be marked INVALID since we're not going to debug random third party
applications that claim we have problems without any details.
(Reporter)

Comment 4

13 years ago
I will call them today to get the needed information.
(Reporter)

Comment 5

13 years ago
Okay, after calling them they gave me a link for the new beta of their Smartcard
Suite - now with Firefox support.... I hope this works out tonight.

http://files.chipdrive.de/file/beta/sco252_CHIPDRIVE_beta1.zip
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
not a bug in Firefox -> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.