Personal Bookmarks disappear from Bookmarks Toolbar

RESOLVED FIXED in Firefox1.5

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: ShareBird, Assigned: Martijn Wargers (zombie))

Tracking

({regression})

Trunk
Firefox1.5
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050720 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050720 Firefox/1.0+

If you customize your toolbar to have the url bar beside your personal bookmarks
(very common for people who has migrated from IE) and minimize the window to the
taskbar on Windows, every time a live bookmarks refresh occurs, the personal
bookmarks will disappear and you will have only the url bar and the chevron on
your Bookmarks Toolbar.



Reproducible: Always

Steps to Reproduce:
1.Create a new profile.
2.Customize your toolbar putting the urlbar and the go button on the left side
of your personal bookmarks on Bookmarks Toolbar. Please see the attached image
that describes the toolbar appearance.
3.Open a new window (Ctrl+N can do the job).
4.Go to the first window you've opened and minimize it to your taskbar.
5.On the second window, right click the "Latest Headlines" folder and choose
"Reload Live Bookmark".
6.Maximize the first window.
5.Go to the second window

Actual Results:  
The urlbar is expanded and the personal bookmarks "Getting Started" and "Latest
Headlines" disappear into the chevron. Please see attached image.

Expected Results:  
The toolbar shouldn't change its appearance.
(Reporter)

Comment 1

13 years ago
Created attachment 189980 [details]
Customized toolbar

Shows the customized toolbar with urlbar on Bookmarks Toolbar
(Reporter)

Comment 2

13 years ago
Created attachment 189981 [details]
The bug

Shows how the toolbar appears after maximizing the window.
(Reporter)

Comment 3

13 years ago
Sorry for the 5. step at the end of descriptions to reproduce it. Was not intended.

Two other informations:

If you just choose to customize the toolbar and click on "Done" the toolbar will
come back to the intended appearance.
It seems to be a regression, since for a few weeks I was not able to notice this
issue. Unfortunately I can't precise when this started to happen.
(Reporter)

Comment 4

13 years ago
I was able to determine a regression point.

It happens on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3)
Gecko/20050714 Firefox/1.0+ ID:2005071406

It doesn't happen on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3)
Gecko/20050713 Firefox/1.0+ ID:2005071306
(Reporter)

Comment 5

13 years ago
The regression was caused by the fix on Bug
https://bugzilla.mozilla.org/show_bug.cgi?id=178120.
Reverting the patch for it solves this problem.
(Reporter)

Updated

13 years ago
Keywords: regression
Version: unspecified → Trunk
(Assignee)

Updated

13 years ago
Blocks: 178120
(Assignee)

Comment 6

13 years ago
Well, the patch from bug 178120 seems good to me.
But it seems to have caused this bug. Probably the BookmarksToolbar.resizeFunc
isn't doing the job well in this circumstance.
It's a bit strange, though, that onChange seems to be getting called when
following the steps in this bug? (from :
https://bugzilla.mozilla.org/attachment.cgi?id=188840 )
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 7

13 years ago
Created attachment 190113 [details] [diff] [review]
patch

I should have done this in bug 266737, it makes perfect sense: don't continue
with the resizeFunc when window.innerWidth = 0. 
I've tested it and I think it fixes the bug.
Attachment #190113 - Flags: review?(mconnor)
(Assignee)

Updated

13 years ago
Assignee: nobody → martijn.martijn
+    if (width == 0) {  // hack for bug 266737
+      window.addEventListener('focus', BookmarksToolbar.resizeFunc, false); 
+      return;
+    };
      ^

Martijn, please remove the trailing semicolon.
(Assignee)

Updated

13 years ago
Attachment #190113 - Flags: review?(mconnor)
(Assignee)

Comment 9

13 years ago
Created attachment 190115 [details] [diff] [review]
patch2

Ok, done
Attachment #190113 - Attachment is obsolete: true
Attachment #190115 - Flags: review?(mconnor)
Attachment #190115 - Flags: review?(mconnor) → review?(vladimir)
Comment on attachment 190115 [details] [diff] [review]
patch2

r=vladimir
Attachment #190115 - Flags: review?(vladimir)
Attachment #190115 - Flags: review+
Attachment #190115 - Flags: approval1.8b4?

Updated

13 years ago
Attachment #190115 - Flags: approval1.8b4? → approval1.8b4+
Whiteboard: [checkin needed]
Checking in bookmarksMenu.js;
/cvsroot/mozilla/browser/components/bookmarks/content/bookmarksMenu.js,v  <-- 
bookmarksMenu.js
new revision: 1.48; previous revision: 1.47
done
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox1.1
You need to log in before you can comment on or make changes to this bug.