Closed Bug 301541 Opened 15 years ago Closed 12 years ago

attachments received using IMAP sent from outlook 2003 clients are corrupted/missing

Categories

(Thunderbird :: General, defect, critical)

PowerPC
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: rhett.eiffler, Assigned: mscott)

Details

(Keywords: dataloss)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

I am running a Mac with OSX 10.3.9 (have experienced problem with all installed
versions of TBird, now using 1.0.5)
My account is an exchange 2000 IMAP on a local area network.
The attachments are usually jpg or mpeg and some are quite small. If a single
attachment is sent it may be corrupted. When multiple attachments are sent the
first can be fine and susequent attachments will be corrupted and some will even
be missing (not even showings up as being attached in the first place!)
Below is a summary of the problem: (this has been tested with several emails
using forwarding)
Sender: outlook 2003 on PC ----> Recipient: TBird XP SP2 = fine
Sender: TBird on PC ----> Recipient: TBird Mac OSX = fine
Sender: outlook 2003 on PC ----> Recipient: TBird Mac OSX = Corrupted
Sender: TBird MAC (forwarding same email) ---->  Any Recipient = corrupted


Reproducible: Sometimes

Steps to Reproduce:
1.recieved email correctly on PC sent from PC, saved the single attachment locally
2.created a new message using the attachment (with and without a written message)
3.sent email to a Mac machine running TBird 1.0.5

Actual Results:  
The single 96Kb(outlook size) jpg attachment became corrupted The image is
viewable with the bottom portion (approx 1/4) missing

Expected Results:  
I'd have liked tBird to have shown the attachment as it was intended!
Severity: normal → critical
Keywords: dataloss
my guess is that this is an Exchange Server bug - do you have the latest patches
for that Exchange server? There's a known bug where using IMAP with an Exchange
server corrupts attachments, doesn't report sizes correctly, etc. It could be a
problem with the mac version of tbird, but I'm sceptical, given that there's a
known bug with Exchange that has similar symptoms.
Summary: attachments recieved using IMAP sent from outlook 2003 clients are corrupted/missing → attachments received using IMAP sent from outlook 2003 clients are corrupted/missing
I have since checked this problem and can confirm that it appears to be on the
Mac where the problem occurs. I logged onto a PC using the user account and
checked the email using outlook 2000. The same emails attachment viewed on the
PC appears complete, but still shows as corrupted on the Mac using TBird 1.0.5
QA Contact: general
I know this bug is for Macs, but I get exactly the same bug on several XP machines and I haven't found a better place to park the info.

I am running many XP machines, with several versions of TBird, from 1.5 to the latest.
Our mail server is Exchange 2003 IMAP.
On many occasions, a Word doc (some are small) has been sent from an Outlook user to a Tbird user.  The Tbird user reports that one of two things has occurred:
1. The email appears blank and no attachment shows
2. The email shows but the attachment is corrupted (actually, it's smaller than the original

Reproducible: Every time with same email and users.  Other emails sent and rec'd by same set of users works fine.

Expected Results:  
No corruption or missing email.
Could you supply a testcase? If yes, please move the message to an own folder and attach its MBOX and .msf file as a zipped archive to this bug. That would be very helpful.
Same bug exists on Thunderbird (2.0.0.9) for Linux (x86). I will try to get the source of an affected mail.
Test szenario:
cat mailtest | /usr/lib/sendmail -t -oi -oem

Mail gets transfered from UNIX to MS Exchange server. Thunderbird receives mail from Exchange server through IMAP.

Problem: The last attachment got truncated or corrupted.
Sorry, today I'm a bit confused with "get" and "become". :(
Anyway I hope you understand my problem.
I think that some lines in the attached postscript file in the mail cause the problem.
Tried to delete every unneeded line from the attachment, so it may be easier to reproduce and find the problem.

Try following command on a unix/linux host:
cat mailtest2 | /usr/lib/sendmail -t -oi -oem

You should see a truncated/corrupted attachment/mail after receiving.
Now I also believe, that it has nothing to do with exchange server. Maybe someone can confirm, because I didn't test it.
http://support.microsoft.com/kb/835643/en-us
its bug of exchange server
Nikolay: I don't think it's that bug, because none of the names of the files in the test mail have "extended ASCII characters" in them.

We really need someone with a Mac and an exchange server to reproduce this. Or Bernd, if you are still able to help, an IMAP protocol log would be very useful. If you could follow the instructions at:
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
and then reproduce the problem, and attach the resulting log here, that would be great.

Gerv
I also have this problem. Emails with attachments, when collected from the Exchange Server by IMAP simply don't appear. I'm using Thunderbird on Windows XP.
Dean, could you save as file any of your mail with such problem and attach it here.
I believe the problems people are experiencing are really the same as bug #92111.  The work around of setting fetch_by_chunks=false works for me.
Rollin, so you confirm when you have setting TRUE value (which is default) you are experience such problem as described by reporter?
Yes, I can confirm that with the default setting of fetch_by_chunks=true I regularly experienced the problem using an Exchange mail server.  Messages larger than the chunk size would be truncated.  This will manifest itself as some or all attachments being corrupt or missing.

Changing fetch_by_chunks=false eliminated the problem.
per comment 15
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.