A copyright-mark 'entity' (©) is displayed as a letter c in a circle instead of original text

RESOLVED DUPLICATE of bug 236465

Status

()

Toolkit
View Source
RESOLVED DUPLICATE of bug 236465
13 years ago
10 years ago

People

(Reporter: Piotr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Moreover, depending on situation, the "©" may be displayed as "©" (as
in Step 3. below) or a 'c' in a circle (as in Step 4.). See the problem
reproduction below.

The same goes for — and – (and maybe some others).

Reproducible: Always

Steps to Reproduce:
1. Make a file "xxx.html" (or use the URL) with such a contents:

  aaa &copy; bbb &nbsp; ccc <br>
  ddd &mdash; eee &ndash; fff <br>
  ggg &amp; hhh &lt; iii &gt; jjj <br>

(yes, I know: not a valid HTML file :-) )

2. Open it in firefox

3. View the page source (I got:

  aaa &copy; bbb &nbsp; ccc <br>
  ddd &mdash; eee &ndash; fff <br>
  ggg &amp; hhh &lt; iii &gt; jjj <br>

)

4. Select (with a mouse) the page's all contents, right click it and select
"View selection's source" (I got: 

  <html><head></head><body>aaa © bbb &nbsp; ccc <br>
  ddd — eee – fff <br>
  ggg &amp; hhh &lt; iii &gt; jjj <br>
  </body></html>

)

Note that in both operations &nbsp; stays &nbsp; , just as &amp; , &lt; and &gt; do.

Actual Results:  
(told above)

Expected Results:  
The two different ways of displaying &copy;, &mdash;, &ndash is rather a bug (I
didn't test other entities).

Maybe it's good to let user decide whether to show such entites as &xxx; or as a
resulting character. I think there should be some option or checkable menu item
to decide on it.
The "selection source" is the DOM source, not the original page source, hence
the different output. The naming was changed in bug 236465 so that it is obvious
that this is the case.
Summary: A copyright-mark 'entity' (&copy;) is displayed as a letter c in a circle instead of original text → A copyright-mark 'entity' (&copy;) is displayed as a letter c in a circle instead of original text

*** This bug has been marked as a duplicate of 236465 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.