Closed Bug 301603 Opened 19 years ago Closed 19 years ago

When opacity is set tu a box, that box appears above a floating box.

Categories

(Core :: Web Painting, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 191830

People

(Reporter: mildred-bug.mozilla, Assigned: roc)

References

()

Details

(Keywords: testcase)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.8) Gecko/20050608 Firefox/1.0.4 (Ubuntu package 1.0.4)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.8) Gecko/20050608 Firefox/1.0.4 (Ubuntu package 1.0.4)

There are 2 boxes.
A is a normal box
B is a floating box and covers partially A
If A has a background and a property opacity:0.7 (for example), A appears above B.
I think this is not normal and A must appear below B.

What do you think ?

Reproducible: Always

Steps to Reproduce:
Use the testcase in Firefox 1.0
Actual Results:  
The gray line with opacity:0.7 appears above the green box on the left

Expected Results:  
The gray line with opacity:0.7 must appears below the green box on the left like
the other gray line without opacity property
Attached file simple testcase
There must be a application/xhtml+xml entry in the content-type menu...
Same problem with Firefox DeerPack Alpha 2
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Confirmed on Mac OS X.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050722
Firefox/1.0+ ID:2005072209
Keywords: testcase
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050723
Firefox/1.0+ ID:2005072308
I see the described behaviour too.
OS: Linux → All
Screenshot form the testcase, on Mac OS X.

*** This bug has been marked as a duplicate of 191830 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.