If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Dragging to dock causes Dock crash, OS X becomes extremely unstable, requiring hard restart

RESOLVED WORKSFORME

Status

()

Firefox
Shell Integration
--
critical
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Adam Conover, Unassigned)

Tracking

1.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When I drag an image to an open application in the Dock (such as Photoshop or
Safari) the Dock crashes. I have reproduced this three times -- the first time,
the dock and the finder restarted (though Firefox was fine), but quickly became
unstable, along with every other program I was running, forcing me to force quit
them and restart. (I couldn't even open the activity monitor or terminal!) The
second time, neither the Dock nor the Finder were able to restart -- they both
hung, along with every other program and the Force Quit dialog. I was forced to
HARD reset my computer. The third time (just now, dragging an image to Safari),
the Dock and Finder both crashed, but immediately restarted, and my system has
not become unstable as of yet (though I rather expect it to.)

I am using 10.4.2, and a clean Firefox install (i.e., new profile, though I did
install a bunch of extensions: Adblock, Web Developer, downTHEMall, Session
Saver .2, Duplicate Tab, Link Toolbar, Favicon Picker, and ChromEdit.)

Reproducible: Always

Steps to Reproduce:
1. Have Photoshop or Safari open on the dock.
2. Navigate to a web page containing a draggable image (i.e., not an image
background.)
3. Drag the image onto the Safari (or Photoshop) icon on the dock.

Actual Results:  
The image doesn't open; programs and system processes start crashing like dominoes.

Expected Results:  
A cached copy of the image should have been opened in the target program.

I am using Gerich's Grapple Classic Pro theme. I am attaching the crash log that
the Dock printed to the Console. (If other logs are needed, please ask and I'll
find them. Sorry, I'm new at bug reporting.)
(Reporter)

Comment 1

12 years ago
Created attachment 190048 [details]
Crash report printed to the Console by the Dock
(Reporter)

Comment 2

12 years ago
Another detail about the way in which this behavior makes my system unstable:
After the Dock/Finder crashes/restarts, the system will occasionally appear to
be stable at first, but as soon as I try to quit any application the app hangs,
forcing me to force quit. At this point I can also no longer launch any
application (such as the Activity Monitor, Terminal, etc.) I am forced to log
out / restart, which, incidentally, I'm about to do right now.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.0 Branch

Comment 3

12 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051028 Firefox/1.6a1

On OS X 10.4.2

I was able to reproduce the problem about 95% of the time by dragging from Firefox to Safari (I don't have Photoshop to test the other problems on).  The Dock and Finder instantly restarted like you described, and Firefox hung and had to be "Force Quitted".  In addition, my system became very unstable. Not only did several other programs hang, but I became unable to open or close any other applications, eventually forcing me to reboot.

I'll attach my crash log.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

12 years ago
Created attachment 201259 [details]
Another Crash Log

Comment 5

12 years ago
*** Bug 316166 has been marked as a duplicate of this bug. ***

Comment 6

11 years ago
This is presumably the same as Camino's bug 300044, which is an OS bug that was fixed in 10.4.4.
(Reporter)

Comment 7

10 years ago
Works for me now -- was fixed awhile ago, actually.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.