Killing one application of Mozilla in the Task Manager, also kills all other instances

VERIFIED WONTFIX

Status

()

Core
Widget: Win32
VERIFIED WONTFIX
13 years ago
13 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
To reproduce:

- Open multiple instances of the Mozilla application
- Open Task Manager (Ctrl-Alt-Delete)
- Close one instance of Mozilla you see

Result:
After a small delay, all instances of Mozilla get closed.
I would expect that only the one I got selected was closed.
If you're talking about the same binary, we don't have multiple instances (like
IE does), they're all the same process space...

Comment 2

13 years ago
Reporter, there is only 1 instance of Mozilla in the Task Manager, whuihc is
used for all windows together.

Comment 3

13 years ago
(In reply to comment #0)
> Result:
> After a small delay, all instances of Mozilla get closed.
> I would expect that only the one I got selected was closed.

The same behaviour can be seen with other multiple-windowed apps (eg MS Word).

Comment 4

13 years ago
window != process
Some apps, especially primitive like Notepad, open a separate process per
document, because they can only deal w2ith 1 document (so, window) at the same
time. Other apps can open multiple documents in multiple windows, for example
most word processors. Other apps will try to assign each document to each own
process on purpose, but that's normally to add the possibility that a single
document can crash your app, without affecting the others. Or to hide that
they've made errors and in the design, and they really can't handle 2 documents
at once. The disadvantage is that it consumes much more memory, and the 2 apps
needs to cooperate very closely together (the user will not even notice).

Both Word and Internet Explorer are in that last category (separate process per
window), but none of the other browsers do this (they're in the second). See bug
117222 for a discussion about on the side effects.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

13 years ago
Ok, thanks for the explanation.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.