Registry entries have "(en)" or "(en-US)" instead of the correct locale (e.g. "(de)")

RESOLVED FIXED in Thunderbird1.1

Status

P1
normal
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: bugzilla, Assigned: benjamin)

Tracking

({fixed1.8})

Trunk
Thunderbird1.1
x86
Windows XP
fixed1.8
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ETA 8/16])

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Firefox and Thunderbird 1.0+ l10n nightly trunk builds

There is still one more l10n issue, when installing localized Thunderbird /
Firefox win32 builds: the created registry entries have "en" / "en-US" instead
of the correct locale (e.g. "de").


AFAIK we have 2 files creating the registry entries:

- config.ini in the installer
  > l10n teams have the possibility to change "(en)" to the correct locale (e.g.
"(de)").

- install.js in mail.xpi / browser.xpi
  > AFAIK l10n teams don't have the possibility to localize the given "(en-US)"
entries

Reproducible: Always

Steps to Reproduce:
1. Install a l10n Firefox / Thunderbird nightly trunk 1.0+ build
2. Have a look into the win32 registry
3.

Actual Results:  
You'll find "en" or "en-US" instead of the correct locale in many registry entries.

Expected Results:  
We should have only the correct locales in the registry.
Why do we need locale code in windows registry keys?
(Reporter)

Comment 2

13 years ago
Maybe this bug could be the reason for some upgrade/update problems. If you have
a look into the install.js files in browser.xpi / mail.xpi, you'll find these lines:

function upgradeCleanup()
{
  // Remove Chrome directory cruft
  deleteThisFile("Chrome",      "US.jar");
  deleteThisFile("Chrome",      "en-win.jar");
  deleteThisFile("Chrome",      "help.jar");
  deleteThisFile("Chrome",      "chrome.rdf");
  deleteThisFile("Chrome",      "installed-chrome.txt");
  deleteThisFile("Chrome",      "app-chrome.manifest");
  deleteThisFolder("Chrome",    "overlayinfo");


This function is not localized to, so in l10n builds this function can't work as
expected!

I'm not sure if all the functions in install.js are still used by the installer?
But if they're used we should fix this.
(Reporter)

Comment 3

13 years ago
This bug is related to bug 301815

Comment 4

13 years ago
The locale may matter to the Java plugin.  Please be careful!
(Reporter)

Comment 5

13 years ago
I've checked the config.ini file in win32 installer. In the past l10n teams were
able to translate this file manually (we were able to change "en-US" to "ab-CD".

It seems as this file would not be localized in l10n trunk builds, too?! Our
german CVS build has still "en-US" instead of "de" in the registry paths.
(Assignee)

Updated

13 years ago
Assignee: nobody → benjamin
Status: UNCONFIRMED → NEW
Component: Other → Installer
Ever confirmed: true
Product: Mozilla Localizations → Thunderbird
Target Milestone: --- → Thunderbird1.1
Version: unspecified → Trunk
(Reporter)

Comment 6

13 years ago
There are several l10n specific files:

- install.js in browser.xpi (for Firefox - fixed in Bug 297813

- install.js in mail.xpi (for Thunderbird)
  (registry keys AND update mechanism)
  (AND the start menu item "Thunderbird &Options" - which should be localizable)

- config.ini used by the win32 installer
  (registry keys)
(Assignee)

Updated

13 years ago
Flags: blocking1.8b4+
Whiteboard: [ETA 8/16]
(Assignee)

Updated

13 years ago
Priority: -- → P1
(Assignee)

Comment 7

13 years ago
Created attachment 192846 [details] [diff] [review]
Move scripts from mail.jst -> ab-CD.jst
Attachment #192846 - Flags: review?(chase)

Updated

13 years ago
Attachment #192846 - Flags: review?(chase) → review+
(Assignee)

Comment 8

13 years ago
Comment on attachment 192846 [details] [diff] [review]
Move scripts from mail.jst -> ab-CD.jst

Patch committed on trunk, requesting branch approval.
Attachment #192846 - Flags: approval1.8b4?

Updated

13 years ago
Attachment #192846 - Flags: approval1.8b4? → approval1.8b4+
(Assignee)

Updated

13 years ago
Depends on: 304987
(Assignee)

Comment 9

13 years ago
Fixed on 1.8 branch.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Keywords: fixed1.8
You need to log in before you can comment on or make changes to this bug.