download manager only pops up if save dialog (for images) is left with "enter"

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: maddin.v, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

if you save an image (right click -> save image as...), fill the fields in the
save dialog and press "enter", the download manager pops up correctly. if you
click on "Save", the images will be downloaded correctly, but the download
manager doesn't pop up...

Reproducible: Always

Steps to Reproduce:
1. right click on an image
2. enter a filename in the save-dialog
3. click on "save"

Actual Results:  
no download manager

Expected Results:  
download manager pops up
I guess that's because the file is already on your computer. No need to download
it once more.

Comment 2

13 years ago
Possibly related to bug 243324, depending on how large the image is that you're
downloading.
(Reporter)

Comment 3

13 years ago
bug 243324 is a bug where the DM windows is not closed, here it is not opened.
in addition, i tested the bug with large images (~8mb) and the bug was
reproducible every time.

Comment 4

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050722 Firefox/1.0+
ID:2005072211

I can't seem to reproduce on Linux. Windows only issue perhaps?
Keywords: qawanted
(Reporter)

Comment 5

13 years ago
ok i tested it with some more images...
seems to be random or size-dependent?

but bug 243324 is still something with closing and not opening i think.
Works for me, other than the issues from bug 243324. Certainly pressing enter
and clicking save do the same for me.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050723
Firefox/1.0+ ID:2005072306
WFM also.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.