Closed Bug 301744 Opened 17 years ago Closed 17 years ago

this happens on sun solaris sparc as well however only when a SELECT widget is hilited

Categories

(Toolkit :: Form Manager, defect)

Sun
Solaris
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 262905

People

(Reporter: tblader, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.10) Gecko/20050720 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.10) Gecko/20050720 Firefox/1.0.6

tabbing to a SELECT drop-down object and then hitting the backspace key takes
the browser back one web page in the history stack.  This may be related to bug
262905
(https://bugzilla.mozilla.org/show_bug.cgi?id=262905).

Reproducible: Always

Steps to Reproduce:
1.go to http://www.google.com/advanced_search
2.enter search text in first text field
3.tab to "results" pulldown and hit backspace

Actual Results:  
browser goes back a page in the history.

Expected Results:  
Nothing?

Backspacing on a pulldown is silly, and would mostly be an accidental keystroke
when entering a form full of information.  The problem however is after filling
out all that info, if you hit backspace accidentally on a pulldown, all that
info may not be available after going "forward" again to recover.
Since I'm on the "backspace=back is evil" side of World War III, I was tempted
to morph your bug into a request to have non-text form inputs eat the backspace
key, but if you hacked in your platform-normal "backspace=pageup" keybinding,
that would make keyboard scrolling in forms a pain, so I'm afraid you're just a
duplicate of bug 262905.

*** This bug has been marked as a duplicate of 262905 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.