Firefox crashes on this site permanently ( happens only on my new x86_64 machine) was good on x86

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: zeroowl, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14 DUPEME, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.9) Gecko/20050719 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.9) Gecko/20050719 Firefox/1.0.5

When I use sites like
www.mininova.org
www.torrentsearch.org
www.torrentreactor.net
The browser crash with
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadShmSeg (invalid shared segment parameter)'.
  (Details: serial 35 error_code 179 request_code 149 minor_code 2)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
firefox-bin exited with non-zero status (1)



Reproducible: Always

Steps to Reproduce:
1.Start firefox on x86_64 platform in 64-bit mode
2.surf to www.mininova.org got to browse categories, switch 2-3 times, 
3.if still not crash make some search.

Actual Results:  
Firefox crash

Expected Results:  
;-) Just working

I am using gplflash and flashblock extensions.
And those sites has enough flash banners.
Please provide a talkback ID for the crash:
http://kb.mozillazine.org/Talkback

Comment 2

13 years ago
it's simillary to 317209

Comment 3

13 years ago
What version of flash are you using? And does it occur with the latest version of Flash? http://plugindoc.mozdev.org/linux.html#Flash
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> What version of flash are you using? And does it occur with the latest version
> of Flash? http://plugindoc.mozdev.org/linux.html#Flash
> 

As mentioned above I am using gpflash, becase there is still no flash for x86_64

Comment 5

13 years ago
Same problem here. Using ubuntu 32-bit with GPLflash plugin:

$ firefox --sync
NP_Initialize
New
SetWindow
SetWindow
SetWindow
Destroy
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadShmSeg (invalid shared segment parameter)'.
  (Details: serial 32 error_code 167 request_code 144 minor_code 2)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Updated

13 years ago
Whiteboard: DUPEME

Comment 6

12 years ago
Same problem.

I have just installed mandriva 2007 on a Dell Dimension 4800 and I am using firefox 2.0, and visiting www.meteo.fr I encoutered the same crash: "The program 'Gecko' received an X Window System error. etc...".

I am using Shockwave Flash 7.0 r25.

Comment 7

12 years ago
(In reply to comment #6)
> Same problem.
> 
> I have just installed mandriva 2007 on a Dell Dimension 4800 and I am using
> firefox 2.0, and visiting www.meteo.fr I encoutered the same crash: "The
> program 'Gecko' received an X Window System error. etc...".
> 
> I am using Shockwave Flash 7.0 r25.
> 

By the way: this is not the same problem as in 317209 since I am running on 24bits and I can see the website wolfemails.net; but I still can't see meteo.fr (or www.mininova.org), and I could under FF1.5
Reporter, do you still see this problem with the latest Firefox 2 and the latest Flash? If not, can you please close this bug as WORKSFORME. Thanks!
Keywords: crash
Whiteboard: DUPEME → CLOSEME 07/14 DUPEME
No response from reporter re: comment 8 -->INCOMPLETE.
Reporter, if you still see this problem with the latest release of Firefox 2 and the latest version of Flash, please reopen this bug. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 10

12 years ago
This is not happens any more.
I believe the problem was with GPL flash plugin.

(Reporter)

Updated

12 years ago
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.