download duplicate file renames rather than query [bug or feature]

VERIFIED DUPLICATE of bug 227343

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 227343
13 years ago
10 years ago

People

(Reporter: john russell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

when downloading a file that already exists, FF deer park 2
simply renames and downloads ... this is a bad idea as it 
causes wasted download time in many cases. options should
be offered to:
1]write over (aka update)
2]rename (ie way it works now)
3]cancel -- user realises he has file -- no need to waste time
perhaps the dialog choices could be toggled by an option setting
for those who like it as is but others really need user choice...

Reproducible: Always

*** This bug has been marked as a duplicate of 227343 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.