If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<chromelist.txt> has broken content/lines

RESOLVED DUPLICATE of bug 331781

Status

SeaMonkey
Build Config
RESOLVED DUPLICATE of bug 331781
12 years ago
12 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 98
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Email answer from Neil:
{{
> I'm puzzled by theses line formats:
>
> [Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050625] (nightly)
(W98SE)
> (I already got at least some of theses in my v1.8b1 W2K personal build)
>
> {{ <chromelist.txt>
> comm\*       content\necko\contents.rdf (netwerk/resources/content/contents.rdf)
> @AB_CD@\% locale necko @AB_CD@ %locale\@AB_CD@\necko (netwerk/locales/)
> @AB_CD@\* locale\@AB_CD@\necko\contents.rdf (netwerk/locales/generic/contents.rdf)
> @AB_CD@\locale\@AB_CD@\necko\necko.properties (netwerk/locales/%necko.properties)
> }}
>
> Isn't there somethnig broken/obsolete/... somewhere !?

When chromelist.txt was first invented all file names were uniquely listed in
jar.mn files. Now those manifests can be filtered and substituted. Unfortunately
nobody bothered to fix chromelist.txt but I would agree that those lines are
broken. Any bug should probably be filed under build config as the fix is
probably to one of the .mk and/or .pl files in the mozilla/config folder.
}}

I wonder what the consequences of this bug could be,
or what the purpose of this file is (nowadays) ?
(Reporter)

Comment 1

12 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060330 SeaMonkey/1.5a] (nightly) (W98SE)

This file has been removed "by" bug 331781 in today's build.

*** This bug has been marked as a duplicate of 331781 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.