FAYT fails if the first search was pasted in and was not found

RESOLVED DUPLICATE of bug 300428

Status

()

RESOLVED DUPLICATE of bug 300428
13 years ago
10 years ago

People

(Reporter: bugzilla-mozilla, Assigned: jruderman)

Tracking

unspecified
x86
Windows ME
Points:
---
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.10) Gecko/20050719 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.8b4) Gecko/20050723 Firefox/1.0+

If the first in-page search a user makes was made by pasting text into the Find
Toolbar textbox and this text wasn't found, every subsequent FAYT search in this
window will fail.

Reproducible: Always

Steps to Reproduce:
1. Open a new browser window
2. Open the Find Toolbar (Ctrl+F)
3. Paste any text which doesn't appear in this page into the textbox (Allizom)
4. Try to search for something which does appear in this page

Actual Results:  
It fails

Expected Results:  
It should work

On step 3 if the first letter appears in the page it will be highlighted and no
indication that the search failed appears.

Using Find Next (or pressing Enter) and Find Previous works but the Toolbar
indicates that the search failed.
(Reporter)

Updated

13 years ago
Flags: blocking1.8b4?
The find matching badly on paste may be related to bug 300428

Comment 2

13 years ago
WFM 

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050728
Firefox/1.0+

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
Bug Triage: edge case - not blocking beta for it.
Flags: blocking1.8b4? → blocking1.8b4-
(Assignee)

Updated

13 years ago
Assignee: nobody → jruderman

*** This bug has been marked as a duplicate of 300428 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.