The default bug view has changed. See this FAQ.

Previously installed and active theme does not display, browser reverts to default theme

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: philippe (part-time), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050723 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050723 Firefox/1.0+

Since 20050723, a previously installed theme that is active doesn't display
anymore. Browser reverts to use the default theme. 
The custom theme is still displayed as active in the Theme Manager.
The custom theme was working correctly with the 20050722 build.


Reproducible: Always

Steps to Reproduce:
1. Have a theme installed an active in your profile
2. Install/upgrade to the  20050723 build
3. launch the browser

Actual Results:  
The browser uses the default theme (Firefox (default) 2.0).

Expected Results:  
Firefox should have used the custom theme
(Reporter)

Comment 1

12 years ago
Additionally, on first start up after installing/upgrading, the tabbar which
should have been visible, failled to paint. But that is apparently bug 301807.
Are there any errors in the JavaScript Console that are for
nsExtensionManager.js or other files that are obviously for the extension manager?
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Are there any errors in the JavaScript Console that are for
> nsExtensionManager.js or other files that are obviously for the extension manager?

Error: Components.classes['@mozilla.org/xpcom/version-comparator;1'] has no
properties
Source File:
file:///Applications/DeerPark.app/Contents/MacOS/components/nsExtensionManager.js
Line: 172

Is the only error, I think. I've since uninstalled the theme (that worked fine
!), and tried to install again, which failed.

For that, I've filed bug 301875: since 20050323: cannot install themes
philippe - from your recent comment in bug 301875 it appears that the symptoms
have changed... is this bug still the same?
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> philippe - from your recent comment in bug 301875 it appears that the symptoms
> have changed... is this bug still the same?

As per my comment in bug 301875, I could install a theme (by downloading), and
once restarted, the browser effectively uses the theme. It is a pity I didn't
back up my profile yesterday, to see if the symptoms have disappeared completely.

Later today, I'll reinstall an old (pre 0723) build, reinstall by theme, and
check that the problem has disappeared completely.
(Reporter)

Comment 6

12 years ago
Last update: I reverted to a 3 weeks old backup of my profile, then used the
0721 build to check that everything was working correctly (theme).
Updated next to the latest 0724 build:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050724
Firefox/1.0+ ID:2005072410

Everything working as expected. Obviously the midair collision mentioned in bug
301875 comment #4 was causing this problem as well.

Marking as WFM ?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.