MS's new download Validation routine won't work with my version of Firefix (MOOX)

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: S.Green, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050516 Firefox/1.0.4 (MOOX M2)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050516 Firefox/1.0.4 (MOOX M2)

I've had a series of 11 emails w/ MS tech support persons trying to get their
new validation routine to work for me.  It just goes into a loop asking if I
want to validate. Regardless of whether I decline or provide a current code#
using their "Genuine Advatange" checker, I am not able to get past the
validation questions.

Reproducible: Always

Steps to Reproduce:
1.  goto (for example) the DL page referenced above for their "Tweak MCE
PowerToy...".
2.  click on the "Continue" button
3.  select "No, do not validate...", and then click "Continue"
4.  click on the "Download" button

Actual Results:  
The 1st page reappears instead of a download process.  The same results happen
if in Step 3 I had selected "Yes, please validate..." and provided a current
validation code.

Expected Results:  
A file download prompt would have appeared for "TweakMCE.msi" with options: 
run, save, cancel.

Based on an 3-page instruction sheet emailed to me by a "Compass Rule Manager"
from <comprule@microsoft.com>, I twice performed system cleanups that was
indicated to assure my WinXP SP2 system was setup properly.
*** Bug 301931 has been marked as a duplicate of this bug. ***
Works for me, even if I hack my useragent to match yours.

If this is an issue with the useragent containing the MOOX bit, then this bug is
invalid, official Mozilla builds would not exhibit the problem.

If this is an issue with Microsoft doing stupid browser detection (which they do
in numerous other places on their website) then this may be Tech Evangelism, if
not invalid.

Since I got it working though, I'd put money on it being your cookie retention
settings, or a firewall/privacy manager blocking the cookie or referer settings.
(Reporter)

Comment 3

13 years ago
You may be right, but to test your guesses I did the following:

1.  I shutdown Zonealarm -- but, no success.

2.  I downloaded and installed v1.06 from Mozilla (not MOOX) -- but alas, no
success.

I do have 10 extension installed:
 1. Answers 1.15
 2. Back to Top 1.0
 3. Bandwidth Tester 0.5.4
 4. ChromEdit 0.1.1.1
 5. Copy Plain Text 0.3.1
 6. Copy URL +  1.3.1
 7. deskCut 0.5.0.0
 8. Download Manager Tweak 0.6.6
 9. Highlighter 0.1
10. IE View 1.2.4

Do you think that any of these has a history of causing this kind of problem?
Forgot to add, give it a go with firefox in safe mode just to rule out any
extension issues.
(Reporter)

Comment 5

13 years ago
I did boot to "Safe Mode with Networking" and retried the routine -- it still
did not work properly with Firefox.
(In reply to comment #5)
> I did boot to "Safe Mode with Networking" and retried the routine -- it still
> did not work properly with Firefox.

Comment 4 meant firefox safe mode:
kb.mozillazine.org/Safe_mode
No further responce - resolving WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

11 years ago
I've not had any problem like this since reporting it 1.5 years ago
You need to log in before you can comment on or make changes to this bug.