If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Show Update History Button for Extensions and Themes

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
--
enhancement
RESOLVED WONTFIX
12 years ago
8 years ago

People

(Reporter: Mike Mason, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050724 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050724 Firefox/1.0+

Can we have a Show Update History button for My Extensions and Themes similar to
the one for Deer Park.

Reproducible: Always

Steps to Reproduce:
1. Go to Tools> Options> Advanced> Update Tab
Actual Results:  
There is not a Show Updates History button in the My Extensions and Themes

Expected Results:  
Give you a Show Updates History button in the My Extensions and Themes
What use would such a feature be?
(Reporter)

Comment 2

12 years ago
I'm of the opinion that knowing what is installed on your computer and when is
always a good thing.
It could also be helpful in identifying what and when a specific version of an
extension is broken.

Comment 3

12 years ago
I have to agree with Steve, I'm not sure I see the value in this. Typically
breakages occur in the following situations:

1. Firefox updates that change core API or code meaning that the extension
   has to be rewritten or changed to accommodate the new version.

2. Extension updates that don't account for cross-platform differences or
   special circumstances.

In the first case, the solution is almost always "get the latest version", which
will solve most cases. The previous history is not relevent to this problem.

In the second case, the problem is newly introduced and a version history isn't
really required to identify the offending update. Since most extensions stick to
specific tasks, users will be able to identify if a common activity worked in
the previous version without such data.
This has nothing to do with Software Update. It either belongs in EM or in Prefs, but more work will be required in EM...

Rob, what do you think?
Component: Software Update → Extension/Theme Manager
Hardware: PC → All
Version: unspecified → 1.5 Branch
Oops, I get cc'd on extension.manager@firefox.bugs so I didn't see this.

I think the value to pain ratio for this is too high on the pain side.
QA Contact: software.update → extension.manager
Version: 1.5.0.x Branch → Trunk

Comment 6

11 years ago
based on comments and lack of activity since end of 2005, marking wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX

Updated

11 years ago
Duplicate of this bug: 376097
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
Duplicate of this bug: 529751
You need to log in before you can comment on or make changes to this bug.