editusers.cgi shows only users in a group without restrict checkbox checked

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: ondrej, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

When I don't restrict a search to one group it still searches only in the group
selected. It may be only PostgreSQL issue.
URI that causes the problem:
editusers.cgi?action=list&matchstr=&matchtype=substr&groupid=<someid>

Reproducible: Always

Steps to Reproduce:
1.create a group
2.let some user register
3.try to find him using editusers.cgi, don't restrict to a group, don't insert
any filter for login name, try to list all users

Actual Results:  
only users in selected group are listed

Expected Results:  
all users should appear

The only solution I found is to manually add the user to the group in the database.
(Reporter)

Updated

14 years ago
Version: unspecified → 2.20
I can't reproduce... Maybe I'm doing something differently. Are you using
visibilitygroups?
(Reporter)

Comment 2

14 years ago
I have only one group in addition to those created by setup.
 id | name | description | isbuggroup | last_changed | userregexp | isactive
 12 | xxxx | xxxx        |          1 | 2005-07-22 . |            |        1
It behaves really strange, I can't list the user no matter what I do.
I tried
editusers.cgi?action=list&matchstr=&matchtype=substr
editusers.cgi?action=list&matchstr=&matchtype=substr&groupid=8
user is in grou 8 by default
only inserting values (4, 12, 0, 0) into user_group_map table makes the new user
(id = 4) visible.
You didn't tell, but it seems like the usevisibilitygroups parameter is switched
on at your installation. If this is the case, then users are only visible if
they are in at least one group that is visible to you.

So it might make sense for you to create a new group, say, everybody, and use
the regular expression .* to automatically have Bugzilla place all users into
it. Give the admin group visibility to this group, and you should be able to see
all users (provided you're a member of the admin group).

Joel, how about we morph this bug, maybe to "usevisibilitygroups unexpectedly
hides users" or something similar? Aiming for docs, a default everybody group,
visibility for all groups for admins?
(Reporter)

Comment 4

14 years ago
Oh, I see, I have usevisibilitygroups set to On. But administrator should have
all groups visible, shouldn't he? In Group permissions I have visible, grant and
inherit rights to the group #12.
When I turn usevisibilitygroups off, the user appears in the list, but it's not
the solution I'd like to use.

Comment 5

14 years ago
Bug 302717 has been opened to make users visible when they aren't in any group,
or when they are in system groups only. So marking this bug as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.