Crash while loading http://www.lcdi.fr [@ nsFrameList::DestroyFrames ]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: olivier.perron12, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

The page http://www.lcdi.fr starts to load and then FF crashes.

Reproducible: Always

Steps to Reproduce:
1. Type in www.lcdi.fr in the address bar and press return
2.
3.

Actual Results:  
FF crashes

Expected Results:  
Load the page without crashing

Comment 1

13 years ago
From reports mentioning lcdi.fr here's one stack:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=7531893
Keywords: crash
Summary: Crash while loading http://www.lcdi.fr → Crash while loading http://www.lcdi.fr [@ nsFrameList::DestroyFrames ]
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050724
Firefox/1.0+ ID:2005072323

WFM
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716
Firefox/1.0.6
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050725
Firefox/1.0+ ID:2005072510
Reporter, please use a current nightly build to verify if it still crashes.
Since 1.0 a lot of that crashes were fixed.

Talkback data:

Stack Signature	 0x00000000 c817a140
Product ID	Firefox10
Build ID	2005071318
Trigger Time	2005-07-16 03:19:46.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	
URL visited	http://www.lcdi.fr
User Comments	Click on "boitier" link then error
Since Last Crash	17 sec
Total Uptime	621 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
0x00000000
nsFrameList::DestroyFrames 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/base/src/nsFrameList.cpp,
line 129]
nsFrameList::DestroyFrames 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/base/src/nsFrameList.cpp,
line 129]
nsFrameList::DestroyFrames 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/base/src/nsFrameList.cpp,
line 129]
nsFrameList::DestroyFrames 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/base/src/nsFrameList.cpp,
line 129]
nsTableFrame::Destroy 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/html/table/src/nsTableFrame.cpp,
line 310]
nsTableOuterFrame::Destroy 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/html/table/src/nsTableOuterFrame.cpp,
line 82]
CanvasFrame::Destroy 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/html/base/src/nsHTMLFrame.cpp,
line 240]
nsFrameList::DestroyFrames 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/base/src/nsFrameList.cpp,
line 129]
nsBoxFrame::Destroy 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 1066]
nsFrameList::DestroyFrames 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/base/src/nsFrameList.cpp,
line 129]
nsBoxFrame::Destroy 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 1066]
nsGfxScrollFrame::Destroy 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 433]
nsPositionedInlineFrame::Destroy 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/html/base/src/nsInlineFrame.cpp,
line 1103]
PresShell::Destroy 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 1868]
DocumentViewerImpl::Destroy 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/content/base/src/nsDocumentViewer.cpp,
line 1242]
DocumentViewerImpl::Show 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/content/base/src/nsDocumentViewer.cpp,
line 1504]
PresShell::UnsuppressAndInvalidate 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 4815]
PresShell::UnsuppressPainting 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 4860]
PL_HandleEvent 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/xpcom/threads/plevent.c,
line 674]
0x778b0c24
XULContentSinkImpl::HandleEndElement 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Depend/mozilla/content/xul/document/src/nsXULContentSink.cpp,
line 875]
0xac02a302
(Reporter)

Comment 5

13 years ago
Just tried the one in 2005-07-25-07-trunk and it doesn't crash.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050725
Firefox/1.0+

(In reply to comment #4)
> Reporter, please use a current nightly build to verify if it still crashes.
> Since 1.0 a lot of that crashes were fixed.
> 
So I resolve that bug as WFM. If it should appear again, feel free to reopen the
bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsFrameList::DestroyFrames ]
You need to log in before you can comment on or make changes to this bug.