Add a link in mail start page to download dictionaries

RESOLVED FIXED in Thunderbird1.1

Status

Thunderbird
General
--
enhancement
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Jérôme Schell, Assigned: Jérôme Schell)

Tracking

unspecified
Thunderbird1.1
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact] has patch, needs landing)

Attachments

(5 attachments)

(Assignee)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8b4) Gecko/20050720 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8b4) Gecko/20050720 Firefox/1.0+

Some dictionaries won't be distributed with Thunderbird due to licences problems.
So I think it should be a good thing to add a link to download dictionnaries in
the mail start page.

Two cases will occur:
- the dictionary is distributed with Thunderbird (compatible licence, for
exemple english dictionary): the link is pointing to
http://dictionaries.mozdev.org/ and tell the user that he can download
dictionaries for many languages from here.
- the dictionary is not distributed with Thunderbird (incompatible licence, for
exemple french): the link is pointing directly to the XPI of the language
dictionary and briefly explain how to install it.

I am attaching two screenshots for these two cases:
- The first in english for the generic case.
- The second in french with explanations saying "You can add french dictionary
by downloading and installing from Tools->Extensions menu this file" and "This
dictionary is distributed under the GNU/GPL Licence and then can not be
distributed with Thunderbird"


Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

13 years ago
Created attachment 190444 [details]
Screenshot in english

The english screenshot.
(Assignee)

Comment 2

13 years ago
Created attachment 190445 [details]
Screenshot in french

The french screenshot.
(Assignee)

Comment 3

13 years ago
Created attachment 190446 [details] [diff] [review]
Patch to add the link

The patch that add the HTML and entity for that functionality.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Assignee: mscott → benjamin
Blocks: 300860
Flags: blocking1.8b4+
Whiteboard: [affects l10n] ETA 27-Jul

Comment 4

13 years ago
Created attachment 190719 [details] [diff] [review]
Simpler patch

Updated

13 years ago
Attachment #190719 - Flags: review?(mscott)

Updated

13 years ago
Whiteboard: [affects l10n] ETA 27-Jul → [affects l10n] has patch, needs review mscott

Updated

13 years ago
Attachment #190719 - Flags: superreview+
Attachment #190719 - Flags: review?(mscott)
Attachment #190719 - Flags: review+

Comment 5

13 years ago
Comment on attachment 190719 [details] [diff] [review]
Simpler patch

Self-approving based on very low risk.
Attachment #190719 - Flags: approval1.8b4+

Comment 6

13 years ago
Fixed on trunk for 1.8b4
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird1.1

Comment 7

13 years ago
Could we have a localization note like
+<!-- Localization-specific information, i.e. how to download a dictionary. -->
in start.dtd also? So the localizers know what to do with the "startpage.extra"
entity.
Should the link not go to
http://www.mozilla.org/products/thunderbird/dictionaries.html ?

Comment 9

13 years ago
That page is not localized, so, no.

Comment 10

13 years ago
I must be missing something because I haven't noticed any change in the start
page (TB 2005073005 auto-updated exe build)

Comment 11

13 years ago
That's correct, there is no text in English because we pre-ship the English
dictionary. This entity is only for use by locales which cannot ship a localized
dictionary for licensing reasons.
Suggest reopening as the new entity is separate of other content...

In a new trunk build (30.07.2005 14:35:00) the start.xhtml has the the new
entity  "&startpage.extra; outside the "indent" div. This forces the localizer
to either specify his own separate styling for the content of "&startpage.extra;
or to start a new div with id="indent" (which is an incorrect double id=""
entry) which has the effect of repeating the background image (Thunderbird logo).

Moving the entity a couple of lines up, so that it's inside the div, will fix
the issue.

(I'd also file a patch myself, but that would require me to DL the source tree
AFAIK, so I'll pass. :( )
(Assignee)

Comment 13

13 years ago
Created attachment 191888 [details] [diff] [review]
Patch to move the new entity in the <div>

This is the patch to move the new extra entity inside the <div> section and
keep the right formatting for that section.
(Assignee)

Updated

13 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #191888 - Flags: review?(mscott)
Attachment #191888 - Flags: approval-l10n?

Updated

13 years ago
Attachment #191888 - Flags: review?(mscott) → review+

Comment 14

13 years ago
Comment on attachment 191888 [details] [diff] [review]
Patch to move the new entity in the <div>

Please land these changes. We're not in the l10n freeze yet.
Attachment #191888 - Flags: approval-l10n? → approval1.8b4+

Updated

13 years ago
No longer blocks: 300860

Updated

13 years ago
Assignee: benjamin → jerome
Status: REOPENED → NEW
Whiteboard: [affects l10n] has patch, needs review mscott → [no l10n impact] has patch, needs landing

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.