XULRunner restarts 3 times on startup even if profile exists

RESOLVED FIXED in mozilla1.8beta4

Status

--
major
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: darin.moz, Assigned: darin.moz)

Tracking

({regression})

unspecified
mozilla1.8beta4
regression
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
XULRunner restarts 3 times on startup even if profile exists

I have not yet confirmed this report, but I'm just filing it here as a reminder
to investigate this problem.  I hear that this problem started occuring sometime
after the 7/19 trunk builds.
(Assignee)

Comment 1

14 years ago
I can reproduce this using today's build of xulrunner on Linux.  All I have to
do is run the simple testcase, and I observe it restarting twice until it tells
me that it prevented EM from restarting the app.  I don't know why EM would be
getting invoked at all since the simple app is configured to disable EM completely.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

14 years ago
Flags: blocking1.8b4?
Keywords: regression
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → mozilla1.8beta4
(Assignee)

Comment 2

14 years ago
This line of code appears to be the problem:
http://lxr.mozilla.org/mozilla/source/toolkit/﷒0﷓

It is comparing against aXULRunnerDir when it should be comparing against aAppDir.

Patch coming up...
(Assignee)

Comment 3

14 years ago
Created attachment 190497 [details] [diff] [review]
v1 patch
Attachment #190497 - Flags: first-review?(benjamin)

Comment 4

14 years ago
Comment on attachment 190497 [details] [diff] [review]
v1 patch

Yeah, I'm pretty sure that's what I meant.
Attachment #190497 - Flags: first-review?(benjamin)
Attachment #190497 - Flags: first-review+
Attachment #190497 - Flags: approval1.8b4+

Updated

14 years ago
Flags: blocking1.8b4? → blocking1.8b4+
(Assignee)

Comment 5

14 years ago
fixed-on-trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.